Upgrade to V24 can't sign in with google

Good day Gibbon group
Hello Rose @admin ,when i upgrade to V24, i can’t use google sign in, it will show the error message
i didn’t change anything.

This is odd, were you upgrading from v23, or perhaps an earlier version? The Oh No message generally means an error has been logged in your PHP error logs, can you check to see if there is an error there? Also, perhaps click the pencil to open, check and re-save your Google settings, as there was a migration for these in v23 that perhaps didn’t complete.

Thanks Sandra, I upgrade from v23 to v24 , i download the v24.zip file from github.com/, i check the error logs , it show this.

[22-Jun-2022 16:39:19 Asia/Taipei] PHP Warning: Class ‘Google_Service’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
[22-Jun-2022 16:39:19 Asia/Taipei] PHP Warning: Class ‘Google_Service_Resource’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
[22-Jun-2022 16:39:19 Asia/Taipei] PHP Warning: Class ‘Google_Model’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
[22-Jun-2022 16:39:19 Asia/Taipei] PHP Warning: Class ‘Google_Collection’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21

and i go back re-save my google settings, still not working.

Hi Kevin, which zip file did you download? There is a specific install bundle that is created for releases, which is why we recommend using the download link from the Gibbon website rather than GitHub (which is generally for development use, and requires additional installation steps for developers to install the vendor directory).

thank you again. i will download agin. re-install. Thank you Sandra, you are the best!!!

Hi @ross i downloaded v24 from the official site of gibbon and i got the same error.
My previous version was v23.

hello @ross
i use Cpanel–>softaculous Apps Installer to upgrade V24
and still get wrong, i check the error_log i find this

PHP Warning:
Class ‘Google_Service’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
PHP Warning:
Class ‘Google_Service_Resource’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
PHP Warning:
Class ‘Google_Model’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21
PHP Warning:
Class ‘Google_Collection’ not found in /home/xapwodeh/public_html/gibbon/vendor/google/apiclient-services/autoload.php on line 21

Hello, Sandra

I am experiencing the same issues at the second attempt. System checks are all ticks and MYSQL and PHP versions are also ticked.

As soon as I refresh the update page, the same error messages appear with a comment stating you do not have access to this page. Attempting to login gives the same Oh no message.

I did try to set up Google access a while ago but being on a shared domain had issues with authentication. I am also pretty sure that I disabled the feature once it didn’t work. I will roll back to see if that feature is active.

Best regards, Andy.

@admin Hello Ross, if you have time, can you help us check it?
Thank you so much

Hi Kevin, sure, I’m happy to help. If you browse your file system, and head to:


do you see a file called autoload.php? If it is there, check the file permissions to make sure that the web server can read and execute it.



@stdavsurfer18 likewise you can check in:


for the same file as Kevin. Let us know what you find!


@admin Hello Ross, when i check v23, i didn’t find that file “autoload.php”
and i try to upgrade to v24, when i click the check link, gibbon break down.

and i check the error_log i find the two error message

PHP Warning: require(/home/xapwodeh/public_html/gibbon/vendor/composer/…/symfony/polyfill-intl-normalizer/bootstrap.php): failed to open stream: No such file or directory in /home/xapwodeh/public_html/gibbon/vendor/composer/autoload_real.php on line 78

PHP Fatal error: require(): Failed opening required ‘/home/xapwodeh/public_html/gibbon/vendor/composer/…/symfony/polyfill-intl-normalizer/bootstrap.php’ (include_path=‘.:/opt/alt/php74/usr/share/pear’) in /home/xapwodeh/public_html/gibbon/vendor/composer/autoload_real.php on line 78

now i am go back to v23.

Thank you.

@admin I trying another way to upgrade system.
It can login with account , but can’t login with google still.

and i get another error message

Hi Kevin, it looks from this like you are using Softaculous to install and update Gibbon, is that correct? Ross

Hi Kevin, it looks from this like you are using Softaculous to install and update Gibbon, is that correct? Ross
Hello Ross, yes,today i am trying use two different way to upgrade. first is using Softaculous, but it stop at last step .even can't open the welcome page.

second is download the file from https://gibbonedu.org/download/
and unzip at my gibbon folder, so the second image i post is come from here, is look likes upgrade sucess. But still can’t use google to login. I also search the autoload.php , it show in the google/apiclient-services folder, the permissions is 644 , then i check the error_log. it shows the new wrong message, i copy the wrong message to the word file.
Thanks for your help.

I had something similar when I tried to upgrade to v24. I couldn’t find anything wrong. We do not use Google, Microsoft, or other integration. After two days of troubleshooting unsuccessfully, I was in CPanel for our hosting provider and updating the main website for our organization. There was a notice that the Gibbon installation needed upgrade according to Softaculous. (We had originally installed Gibbon several versions ago using Softaculous.) I clicked upgrade and it gave an error indicating PHP was at version 8.something (maybe 8.23… I don’t remember exactly.) It indicated the maximum PHP version that Gibbon supports was 7.4.30 or something, and offered to change it. It did, and everything began working. So my suggestion is to make sure your hosting provider doesn’t automatically upgrade PHP versions for the Gibbon site, and also remain aware of the range of PHP versions Gibbon uses for each new version.
Your situation might be different, especially if you use Google or other integration.

Thank you GlennS,
i check my PHP version, is 7.4.30, maybe is something wrong my other php files, because
i change some column of my database, hope Ross can save me.

Hi GlennS, thanks for contributing and helping Kevin : )

Hi Kevin, Softaculous is great for getting up and running quickly, but we don’t test upgrades on it, and so you are a little less covered there than if you install directly.

In your screenshot about it mentions a duplicate entry in a table, which makes it sound like the update has partially run already. If you are able to email me details of your CPanel to support@gibbonedu.com I can see how much of the update has run, and perhaps finish it off manually. This is a little time consuming, and I’d not recommend you try it, but I am happy to have a go.

Customising the database can, sadly, cause such issues.



Thanks Ross,
“Customising database”!!!
Maybe that is the probram, i am so thanks for your help.
i will email the information what you need.

Hello Gibbon Group, before i used “Third Party Settings”,setup the google account login
but after upgrade to v24, the google account login is failed. i try anything i can, it still happened
,so i turn it off. but when i check the error.log. it looks odd,the error.log growing to 52mb,
and almost all the error message is from google service, and it happened every min.

really need help, thank you.