Redirecting to localhost

Hi…Umm plz don’t be mad if this has a simple answer.I installed gibbon yesterday and logged into my gibbon account.But when I click any link like school admin or even the notification icon i always get redirected to localhost.I run gibbon on xampp. And also how to log into gibbon i did not get a login page i always go from my history.

Hi Matheesha, welcome to the Gibbon community! No problem at all, you’re welcome to ask any questions here.

It sounds like you’ve encountered an issue that a user recently reported, which seems to be related to Xampp not saving the Absolute Path correctly on installation. Can you please try the following solution and let us know if it works:

i have same problem what should i do

1 Like

Hi @sandra
I am trying to test gibbon with xampp to use in our school but ran into a problem that I am struggling to solve.
I saw the post mentioned the absolute the gibbonSetting table: absolutePath and absoluteURL.
I have tried this solution and the paths are correct (according to me :see_no_evil:) but is still redirected to the Xampp Dashboard if 'n try to access any links.

Do you perhaps have another solution or explanation for this problem?

Hi @marisam, welcome to the Gibbon community! I hope to have this issue fixed for the next update. In the meantime, the next things to check are that the absolutePath and absoluteURL will often cache in the browser session, so try clearing browser cache or use a private tab. Also, it looks like there may be some backslashes in your absoluteURL, so see if you can change these to forward slashes before clearing cache, then test it out. Hope that works!

1 Like

Hello, I was able to solve this, by changing the absolute paths with forward slahes

1 Like

Worked for me too… Thanks…

Hi, the thing is that from some reason, the bar between localhost and the repository name is backwards. Son instead of localhost/gibbon, it automatically saves it like this localhost\gibbon

Thanks! We’ve fixed this in the development version, v27, so hopefully this issue will no longer occur in future versions.

1 Like

I have the same problem but at the loss at what youre saying. Where do i go to change these paths? Which files? Which folder? Sorry … am a beginner

Hi @Lucky welcome to the Gibbon community, sorry to hear you’ve run into this issue :disappointed: To fix it, you can go into your Gibbon database using the command line, or a tool like SequelAce or PHPMyAdmin. Then, edit the gibbonSetting table and look for the setting called absoluteURL. The slashes should be changed to / (forward slash) anywhere you see a \ (backslash). Then, be sure to clear your browser cache (to clear the session cookie) and reload. It should redirect correctly after this.

If you want to install locally instead of XAMPP use Laragon, it creates a url foldername.test all the urls work fine and navigation is the same as if it was on a live server

1 Like