how to upgrade?


i just wanted a clarification on how to upgrade. Is it as simple as downloading the core 11 file, unzipping it, and replacing all your existing files with the new ones, aside from config file and uploads folder?

athar1, you pretty much have it correct in your post above. The only complication is updating the database, which the system can do for you. Check out our short document on how to do this: Ross.

thanks, i got it done. it worked, but there was only one problem. 

Google authentication is not working. I have even deleted the project from developer console, and created a new one, and made sure i changed the directory path to /lib/google/index.php 
and also i have changed the settings in system admin

the problem i get is that the authentication page (google login) works, but once I have logged in, then it redirects to the redirect page, but it doesnt display it. I just get a blank page. 

anyone have any idea


That is a problem! The blank screen probably means there is a PHP error, that is being logged, but not shown on screen. Can you check the log and locate the error (or turn on error display using php.ini). If you share the error with me, it will give me a better idea of what is going on.


apologies for the ignorance, but where is the php.ini file to edit? (i’m using filezilla for ftp here)

I found this line: error_reporting(0)
in the default.php file

or is this going to be in php admin in my server cpanel?

athar1, it really depends on what OS your host is using, and how it is set up. They may not give you direct php.ini access, but some kind of workaround should be available. Ask the support team at your host. Ross

i figured out how to display the errors. the OS that is being used is CentOS, this is the error messages:

: Cannot modify header information - headers already sent by (output started at /home/rochdale/public_html/gib1/lib/google/index.php:86) in /home/rochdale/public_html/gib1/lib/google/index.php on line 113

Warning: session_destroy(): Trying to destroy uninitialized session in /home/rochdale/public_html/gib1/lib/google/index.php on line 128


I generally run with warnings off, as there are a few floating around the system from Gibbons younger days: with warning’s off, they don’t cause problems. With them on, they do. I have fixed this warning in v12, and if you let us know of any others you find, we will fix them too. The fix is backwards compatible, so you can download the relevant file from:

Let us know how you get on.



thanks for the fix Ross,

however I’m still getting this error and no luck logging in:

Warning: Cannot modify header information - headers already sent by (output started at /home/rochdale/public_html/gib1/lib/google/index.php:86) in /home/rochdale/public_html/gib1/lib/google/index.php on line 113

The second error (above post) is no longer being displayed


This is odd. Can you please add as a user on your site, and send me the URL, so I can try and login?



i emailed you at that address



Thanks. Got the email, and tried to log in, but seeing this error:

Warning: date(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in/home/rochdale/public_html/gib1/lib/google/index.php on line 233

I have written a fix for this, which is available in the following commit:

Can you upload the relevant file, and see if it fixes the issue?


Thanks for trying, i really appreciate your time and effort, but I still see this:

I am still unable to login and receive the same error messagge:
Warning: Cannot modify header information - headers already sent by (output started at /home/rochdale/public_html/gib1/lib/google/index.php:89) in /home/rochdale/public_html/gib1/lib/google/index.php on line 116


Odd that we have never had an issue with this before. Must be something to do with server config. No worries, though, as I think I have now found the problem…and fixed it in this commit:

Let me know how it goes!



thanks Ross!! it works, finally!

I really appreciate all your time and effort for this fix.

I don’t know if this is a problem with my server config, as I did not have this problem on v10. Could it be anything to do with my server being http and not https?


Happy to help…and thanks for sticking with it to help us solve this bug. People like you are a great help to our community, as you persist instead of walking away : )

I went to university in Lancaster…not a million miles from where you are in Rochdale. Small world.


wow, thats not too far at all :slight_smile:

thanks again for the fix, logging in should be less painful now!

I would like to re-take this topic. I have version 12 and obviously I want to go to v13. I already created backups of all files and folders in my PC, and also the SQL database has been backed up. Now I unzipped version 13, ready to upload and replace old files, the question is, do I have to make exceptions for some files and folders?, because I use Filezilla and during the updating process it is going to be asking if I want to replace files and folders, I read the first comment on top saying the following “aside from config file and uploads folder?”, what does that mean?

Adolfo, good question. The downloads don’t include /config.php and /uploads, which are files/folders that you would not want to replace. So, you are safe on that point. I believe the instructions you are referring to are outdated: can you let us know where you saw them?

Other than that, you would not want to overwrite any modules or themes you have uploaded, but in my experience Filezilla will not overwrite whole folders, it will just do the files in the folders.


Thanks Ross, i saw instructions on top of this topic, the very first question. Look at the "Athar1! question, at the end, on top.
Finally, I understand, the process is just to upload files from version 13 to overwrite version 12?, and, if filezilla ask to replace files and folders I just click on ok?, seems to be this is a silly questions but i just want to be sure !!