Why are there errors overlaying the right sidebar links etc?

Hello… I am new to Gibbon, though not to developing and deploying web apps. I am looking at Gibbon as a possible solution for managing team member education within a large humanitarian organization. Anyway, I am piloting the application locally on my laptop. I noticed that there are some error messages overlaying the right sidebar, making the links in that area inaccessible.
I see that message as grey text, overlaying the links. The messages can be selected, and here is an example "
Warning: ini_set(): A session is active. You cannot change the session module’s ini settings at this time in B:\xampp\htdocs\gibbon-core\src\Gibbon\session.php on line 53

Warning: session_cache_limiter(): Cannot change cache limiter when session is active in B:\xampp\htdocs\gibbon-core\src\Gibbon\session.php on line 54
0 x "

I’m wondering is this is how the messages are intended to be displayed, of if perhaps something is wrong with my installation.

Hi fractal815, welcome to the Gibbon community! :smiley:

You’re right, those messages aren’t meant to be there. Looks like they’re PHP warnings rather than a fatal error. In most cases error reporting is only turned on for a development or testing server and would be off on production. This can set through the php.ini on your server, and also as of v15 setting your install type to Production in System Admin > System Setting will prevent the display of PHP errors (they’ll still be logged to your server depending on your configuration).

The source of the warnings is an interesting question though. I haven’t seen them during development, however I’m running on MAMP rather than XAMPP so this could be part of the difference. Out of curiosity, can you post a screenshot of your settings from the System Admin > System Check page. As above, it’s not a fatal error, but I’d still be keen to sort it out if it’s something that may affect other XAMPP users.


Hello Sandra,
Thanks for the response… Here are some screen shots…

Opps…I see that first snap got cut off…here’s another…

Thanks for the screenshots. It looks like PHP 7.2 has become a bit more strict with session-related functions and has added some additional warnings that were not present in previous versions: http://php.net/ChangeLog-7.php#7.2.0 In this case it appears the PHP warnings are coming through with the notification refresh script.

PHP 7.2 is a pretty recent version, it’s not part of the testing for release prep so this one got through unnoticed. Luckily they’re just notices and nothing fatal, you can silence them by setting display_errors` to Off in your php.ini or setting your Gibbon install type to Production.

I’ve made a note in the v16 development road map to address these for the next release. Thanks!!

I have been experiencing the same issues and I tried both of the fixes mentioned above without success. Has anyone out there figured out how to fix this? If so, please share. Thanks!

Hi vlaoic, can you tell me more about the server setup you are on? Is it self hosting or purchased hosting? Real server or virtual? OS? Thanks!

HI, I am using XAMPP 7.2.1. I am using localhost.Windows 7. the error message is:

Warning: ini_set(): A session is active. You cannot change the session module’s ini settings at this time in C:\xampp\htdocs\gibbon15\src\Gibbon\session.php on line 53

Warning: session_cache_limiter(): Cannot change cache limiter when session is active in C:\xampp\htdocs\gibbon15\src\Gibbon\session.php on line 54

What so these ini settings do? CCould I just edit them out of the file listed in the errors?

Hi vlaoic,

This certainly looks like a case where PHP warnings and notices (which are not fatal, they’re mostly used for development) are being displayed. In this case it’s happening because you’re using PHP 7.2 which is a recent release and has added some new warning messages related to sessions.

If you’ve tried the above suggestions and haven’t had any luck, you could try adding the following line of code to the bottom of your config.php file right before the <code class="CodeInline">?>.

`ini_set('display_errors', 0);`

Feel free to check out the PHP docs to learn more about what this line does:

Hope this helps!

YES! Thank you so much Sandra!