User Permissions

I get this message at the bottom of the Manage Permissions page:

php.ini max_input_vars=
Number of inputs on this page=2220
This form is very large and data will be truncated unless you edit php.ini. Add the line max_input_vars=5000 to your php.ini file on your server.

I have tried to change the line max to 5000 by updating the .htaccess file in the Gibbon folder on my server. However, this ends up with a Internal Server Error page being produced when accessing the Gibbon interface.

Any ideas how I can stop this from happening?

What server Operating System are you using?

Adam, it is possible your hosting company has blocked you changing this setting for performance/security reasons. I would try hosting support to see what they say.

They have told me that I have access and can do it. No idea of operating system.

Adam, I have just tried to put the offending line at the start of the file, instead of the end, and it seems to work. It is live on your server now, so have a go, and let me know if there are any issues.

Same issue :frowning:

Adam, that’s a shame. I have rolled back the .htaccess change, so site should be OK now. I would speak to your host about this, as it seems like a server config issue of some kind.

They are not very helpful. I will persist!

Note from provider:

I looked at your .htaccess file, and the problem should be easy to fix…

Couple things:

  1. the error log shows the syntax errors
  2. the documentation for this is at: (search for: php_value)

What you want is:
php_value max_input_vars 5000(press enter here to create a new empty line)
(empty line)

Also, there should be a new line after ‘5000’, otherwise it won’t be properly read in by Apache as it is not a full line… Also make sure it is in Unix line feed mode (LF) and not Dos (CRLF)

In Unix, a line is considered to be terminated by a trailing ‘LF’, and without that, ‘php_value’ would not be properly parsed as it is not a fully formed line…

Tried. No luck.


Some good investigation here! Can you remove the current contents of the .htaccess file (it is not vital, just tidying up), and try to have only php_value max_input_vars 5000?


Doesn’t work. The service provider has finally realised that we are on a PHPML incapable server. They are upgrading the server for us this week to enable this to happen. Keep you posted.

Upgrade resolved issue.