URGENT HELP! (image/logo) in Template builder not uploading

Hello team, we’ve been using Gibbon and recently one of our sections has started using the reports module but unfortunately I cant upload image using {logo,image and other components in template builder}.

At first I thought its permission issue but then after setting up everything properly and trying different options its confirmed as a bug :https://github.com/GibbonEdu/core/issues/1376
Reported 2nd July 2021.

kindly how do I go about this because all teachers entered marks and we are ready to generate report cards but the ability to include a logo+signature or image media is not possible at the moment.

kindly advice


Hi Kelvin, thanks for flagging this issue. I’ve had a chance to look into it and it appears there is indeed a bug, related to the way v22 changed the custom fields functionality. I’ve fixed the bug here in v23, you can apply the same patch to your system by copying the file over or making the same changes.

It looks like the reason it wasn’t generating an error message is related to the way browsers handle file uploads, there was a syntax mismatch in the name of the file input, so the $_FILES array was silently failing to be submitted from the browser ?

Thank you so much… this was kinder an emergency because one of our sections it was their first time trying to generate reports so a did a temporary solution by trying to upload manually and directly from the DB( copying paths and files to necessary locations and uploading those images in the uploads folder …lot’s of work but it was a temporary solution to just make sure things are running smoothly…



I have made the changes but the logo does not appear on the report:

Can you confirm that the logo saved properly in the template? After making the change you may need to re-upload it as well. This will narrow down if the issue is still in the uploading of the image, or somewhere else.

Can you confirm that the logo saved properly in the template?

I am not sure where/what to check.

I have re-uploaded the logo, but still no logo in the report. And the same thing is happening with v23 that I just installed. I see the user’s profile picture, but not the school logo.

Hi Tieku,

In the Template Builder, it may help to let us know which template section you are using. Then, when you edit it, do you see an option to upload the logo? After uploading and submitting the form, do you still see the logo in the form?

If the logo is present in the form but not the output, do you see it when you use either the Preview HTML or Preview PDF options, or is it not displaying on both?

Well Sandra I am actually laughing at myself. I was not promoted to upload a logo and thought the report shares/uses the school site logo. The (New) Logo is showing up on reports now.

Great to hear. The logo for the site can often be offset to the left, so I didn’t program the templates to re-use it, which is why there’s a logo upload option. Also makes the template more flexible. Glad to hear it’s working now.

@ross , i have made the changes to the CustomFields.php file according to this link beside - https://github.com/GibbonEdu/core/commit/701cffe0cadbec3bbbff9e58e3d9b76552253f8a but it is still not showing my school logo in the report.

The problem is solved

Hi! Can you please explain how you have solved it? :wink:

In version 24.00 were the changes described here reversed:


I could not upload a logo in Template Builder till I made the changes described.


Strangely yes, this change did somehow get reverted when the new Form Builder was added at the end of the v24 dev cycle. I’ve made a fix here: https://github.com/GibbonEdu/core/commit/144ed134a18e97a4c939e20a5852bbaeaeac5765

@ross Hi, just a reminder, the code uploaded on Softaculous (V24.0.01) is still the old one, I needed to change the code by myself in order to upload the logo in Template Builder.

Strangely yes, this change did somehow get reverted when the new Form Builder was added at the end of the v24 dev cycle. I've made a fix here: https://github.com/GibbonEdu/core/commit/144ed134a18e97a4c939e20a5852bbaeaeac5765

Thanks henriquexu for the heads up!