Uploads folder server writeable

Greetings Gibbon Team!

I have tried several times on my command line to get my uploads folder server writeable (chmod 755 in several iterations and it seems to have gone through), but the file permissions in my system check still shows that it is not writeable. Any help is appreciated.


Hi Kevin,

Sometimes it’s not necessarily the file permission chmod itself, but the ownership of the file. The chmod will tell the system who, within the file owner, group, and public, can access/write those files. If the web server is not either the owner of the files, or in a group that has access to the files, then it will still not have permission regardless of chmod. You can generally see the file ownership with the ls -l command. Generally, I run a system with the ownership set to www-data (which is the apache/ubuntu web user) and then whichever your main SSH/FTP user is (ideally, one that is not root) would be part of the group that has access. You can set ownership and groups with the <code class="CodeInline">chown and chgrp` commands. Be sure to also run these commands with -R, so any changes are recursive to any files already in your uploads folder.

Hope this helps!

I will give it a go, Sandra–thank you as always for looking out for me!

Changing the chown solved the problem, Sandra. Thanks again!

Great to hear!

Can you please write here what chown and chgrp command you typed?
I still can’t manage this
Thank you

I’m running on Ubuntu 22.04 and used chown -R www-data:www-data [directory] to get this set, @dardiv. I hope that helps!


1 Like