Uploads folder permissions and PHP setting

After installing Gibbon successfully on a shared host using Softaculous, I’ve tried (to no avail) to clear these errors from the System Check:

Any thoughts on what I’m missing? I’ve attempted configuring permissions (through Filezilla, 755) and updating the .htaccess files (uploads and htdocs folders) according to Post-Install & Server Config info given. I wonder if my web host (InfinityFree) is even using these files, since any changes I make do not appear to affect anything. Thanks for any help you can give.

I’ve been able to correct some of my .htaccess mistakes to update some of the php settings:

However, these two error checks still remain. Could the allow_url_fopen error be a typo in the code (i.e., 0n versus on)? Also, I’m still scratching my head over why “Uploads folder not publicly accessible” is giving an error. Any ideas? Thanks in advance.

It looks like it was a security setting with my shared host:

Since this was a dead end, I started over with a VPS and have since got it working (everything passes the system check).