Upgrade to version 18

I’ve tried to upgrade our databse to v18 after being told that our current version (v16) was out of date. I have copied the files to the relevant folder (on our webspace, not a local drive) and the system tells me that the files have updated correctly, but I get a lot of error messages when trying to update the databse.
I’m a bit worried about rolling back the old database (I’m not very computer litterate and worried I might lose all our data). I’ve copied and pasted all the errors in the attached Word document.
I saw another poster had provided an answer/solution to a similar problem, but I just don’t know where to start and could do with a bit of hand-holding.
If not, I guess I’ll roll back to version 16!
Thanks in advance,


It looks like the update has already been run, which is odd. To confirm this, can you please check the result of the final database update command in v18.0.00:

UPDATE gibbonAction SET name=‘Manage Custom Fields’ WHERE name=‘Manage User Custom Fields’ AND gibbonModuleID=(SELECT gibbonModuleID FROM gibbonModule WHERE name=‘User Admin’);end

If you look in table gibbonAction, do you see an action named Manage Custom Fields or one called Manage User Custom Fields.

If it is the latter, then the database update has run, and we just need to let the database know that it is indeed up to date.

Not sure what might have led to this scenario!



Hi Ross,
Thanks for getting back to me. I only see the action name “Manage Custom Fields” in the gibbonAction table.
I’m afraid I don’t know how to check the result of the final update command, so I’ve asked advice on that and will get back to you when I have an answer on that front.
I’ve tried to get the previous version files back onto the server, but it did more harm than good. Now I can’t log in (see attached screenshot).
I can see all the details in the database, but I can only run a new install (creating a new database) and not install and link onto the existing database.
I’m not sure what my next option is. I don’t seem to be able to copy the data into a new database either, so I just don’t know what else to do next.

Thanks again for your help. It is very much appreciated.

In the end, I’ve wiped everything out and restored my backup files (I’m really pleased I followed the advice and backed up everything)
In might try and make a copy of everything and see if I can manage the upgrade, but I’ll stick to V16 for now :frowning: