Updating to v20 - encountered "Failed to upload"

Updating to v20 - encountered “Failed to upload”

Good Day Admin,
Yesterday, I updated my 19 to v20.
Unfortunately, under the folder vendor, i encountered lots of error “Failed to upload” as shown in the following example:

I tried to repeat the upload on another Laptop, still, the same error happened.
I wonder what seems to be the problem.


Around 45 files failed to upload, from various folders of lib, vendor and modules.

Hi Radz,

I’m not sure from the screenshots what type of FTP client you’re using for upload, it looks like the issue is in the file transfer rather than the file itself. Perhaps check the file permissions? Or google the error “URI must be a string or UriInterface” related to the FTP client you’re using. The other option is to try a different client, I have used FileZilla for years and haven’t had any issues.

Hope this helps!

Thank you Admin Sandra
The Host i am using is Hostinger. I symply Drag-and-drop the files.
I started with v17, and i did not encounter this error when i upgraded to v18 and v19.
I will explore filezilla then.

Luckily, systems seems to be working fine. And the 11-chateracter Course short name was not truncated.

Again, thank you for the quick response.