Unable to login

Hi all, I installed v19.0 in a new hosting and took my database from my old hosting and installed in the new one as old hosting had expired and not getting proper customer service and was getting the error
Oh no! Something has gone wrong: the Gibbons have escaped! An error has occurred. This could mean a number of different things, but generally indicates that you have a misspelt address, or are trying to access a page that you are not permitted to access. If you cannot solve this problem by retyping the address, or through other means, please contact your system administrator.

Now when i try to login after importing the new database it takes me to the old hosting domain name. and I get the error message of the old hosting. The url also changes to the old hosting url. Is there any way this can be fixed…

Sounds like a common issue occurring with hosting changes.

Adjust the following two variables in table gibbonSetting:

  • absoluteURL
  • abolsutePath


Hi Meierrom,
I changed the absolute URL and Absolute Patch in myphpadmin gibbon settings. But still the same error. When I check the source code of the login age i see my old domain still listed there.
Restarted server too. But no changes.

Hi Paschal,

Changing the absolute path and absolute URL should do the trick. They’re both saved in session cache via the browser though, so after changing them be sure to clear the cache and/or try a different browser to narrow down if its server-side or client-side.

Hope this helps!

Hi Sandra,
Thanks for the reply. Well i cleared browser cache and then my site loaded without any images loading. I tried loging in as admin but 404 error. my URl looked like this on the page 404 error after i tried logging in

My installation was done on google cloud hosting Centos
installed aapanel on aapane installed php 7.2, mysql 5.6.44, myphpadmin 4.7 Nginx 1.17.1
gibbons installed on www/wwwroot/sitename.com

Before i imported the new database it worked fine and could login as admin etc. all images loaded everything was fine. Now the error after importing the new database.

on gibbon settings changes were made on absoluteURL - abolsutePath

any idea what could be wrong why is my url on the 404 error page repeating.


ok got it sorted out. I removed the website site name (www.XXXXXXXXX.com) and left it blank in absolute URL and in the absolute path I removed the www and left only /wwwroot/sitename.com and now the image everything loads. I have difficulty logging in as the admin now but I an login as a student.
There is also a text that shows up
SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘messageWallPin’ in ‘order clause’

Hi Paschal, that last issue looks like your database is not up to date. Head to Admin > System Admin > Update, and you should be prompted to run the latest database updates. v19 is set to detect this need and redirect you to the Update page, thus avoiding this issue. I wonder why that is not happening? Thanks, Ross.

Hi admin,
I am unable to login as the admin. tried changing the password in phpmyadmin used MD5 and changed the password but still unable to login. Any idea how I can access the password.

Hi Paschal, that is odd. You can run the update using [absoluteURL]/update.php, without being logged in…and this might solve the admin password login. I am not sure that it will, but worth a try. Let us know.

Hi Ross,
I tried the update now i get the error- it says gibbons has escaped.

This is basic info of whats loaded in php.ini
Core date libxml openssl pcre sqlite3 zlib bcmath ctype curl dom filter ftp gd gettext hash iconv intl json mbstring SPL session pcntl standard PDO mysqlnd pdo_sqlite Phar posix Reflection pdo_mysql shmop SimpleXML soap sockets mysqli sysvsem tokenizer xml xmlreader xmlrpc xmlwriter zip imap

My database engine is InnoDB should i covert it to MyISAM

I have attached my php conig image

Two things jump into my eyes:

  • we don’t use short open tags
  • set display_errors to on to get error messages in the browser


Hi Paschal, well done for persisting here. Roman is right about short open tags, but having it on should make no difference. However, displaying errors on page will allow you to quickly see what the error is. Another way to see errors is to look in the PHP log. I tend to have display_errors on in development and off in production. Gibbon then adds a layer of showing or hiding errors depending on whether you have it set to Development, Testing or Production in System Settings. Let us know what error you are getting! Ross

Hi Ross and Roman,
Thanks for all the help. I Did make the changes
short_open_tag off.
display_errors on
But still the same.
Well i did a uninstall and reinstall of gibbons made the changes in the php.ini and i can now login as administrator without importing the old database backup
I noticed that php 7.2.18 was not letting me change the max_input var to 10000 it was showing up as 1000
and when i checked the phpinfo it showed 1000. But in my php.ini it showed 10000 after the changes

I downgraded my version now to php 7.0 again made changes in php.ini and now system check shows all fine. I am reluctant to import the old database from my version 18.0. Because I did spend a lot of time. Think I will use the import from file option and start from scratch.

Guess the error was with the 7.2 but still wondering why.

Thanks for the help Ross, Roman and Sandra.

Great to hear that it is working, but sad that there is some lingering uncertainty as to the cause, and that it took up much of your time. Let us know how it goes from here!

Hi Ross,
Finally i got my database transferred to the new hosting. Problem was the old hosting had php 7.3 and the new ones first 7.2 had issues, Php 7.0 also after updatig database from old server had problems.
Installed Php7.3 and that fixed database. But now i have one problem everything works except
system admin - system check get error gibbons has escaped.
I made all required changes in Php.ini but when i check phpinfo max_input_var is still 1000 even though i changed it.

Hi Paschal, my guess would be that your host has disabled your ability to adjust this setting, and so you may need to ask them how it can be amended. This is something @ross has mentioned fixing in v20: it only applies to the Manage Permissions page, and so we are looking at what we can do to fix that page.

For the escaping Gibbons, unless this is a 404 error, it almost always leaves a trace in your PHP logs. If you can share the relevant log entry, we can offer some suggestions.

Good luck!

HI Ross,
well got it fixed used SSh to edit and save php.ini as root user and that fixed the issue with the max_input_vars
another issue i was facing when checked the error logs showed systemsettings.php line 60 when I checked the same it had to do with the absolute path. I had set my absolute_path to /wwwroot/sitename but it should have been /www/wwwroot/sitename
As of now everything is fine. Thanks a lot team for replying and helping me out.

A happy ending. Great to hear that your persistence has paid off : )