Translations not working

I have added the Thai language, however, if I set the Thai language as default nothing changes, am I missing something?

On our server, I have installed Thai locals
On my desktop machine, I have added Thai language
I have restarted nginx and apache server

I have previously used i18next in some of my web projects, this framework worked perfectly without the need of adding locals to the server.

I thought by changing the language - all the menu text etc would change, I tried to set Thai as my preferred language, but that also has no effect.

Ideally the system would be in English and our Thai staff could choose Thai as their preferred language so they would see all the text in Thai?

As a workaround, I have created a widget

<div class="gtranslate_wrapper"></div>
<script>window.gtranslateSettings = {"default_language":"en","languages":["en","th"],"wrapper_selector":".gtranslate_wrapper","switcher_vertical_position":"top","flag_style":"3d","switcher_text_color":"#f7f7f7","switcher_arrow_color":"#f2f2f2","switcher_border_color":"#161616","switcher_background_color":"#303030","switcher_background_shadow_color":"#474747","switcher_background_hover_color":"#3a3a3a","dropdown_text_color":"#eaeaea","dropdown_hover_color":"#748393","dropdown_background_color":"#474747"}</script>
<script src="" defer></script>

Any suggestions to get the built in translations working would be great or possibly a feature request to have a language widget to allow users to choose the language they want to use.

Ok I got it working, I had updated the wrong php.ini file

for anyone running nginx as a reverse proxy, the ini file is here
sudo nano /etc/php/8.2/fpm/php.ini
Not this one sudo nano /etc/php/8.*/apache2/php.ini

Works as expected main system English, if user chooses Thai then they see everything in Thai


Great to hear you got it working, and thanks for sharing your solution should anyone else have the same issue.