Template builder show no core or additional ites to drag and drop

this is odd
a fresh v22 install, heading to the template builder , where I assume it generates fake data and allow us to build the reporting template. I created a reporting cycle and put some criteria and scope (although I thought it is not neccesary for designing the template).
there were no items to drag and drop from the write side (as per the attached screen shot).
where shall I begin to fix it.

another thing, what does stylesheet field shall include?

thank you

Hi taha, one level up from this page, in Template Builder, you’ll see an option called Manage Assets. Click on here:

Under Manage Assets, you can then click on the Scan Asset Directories link:

This will load up the core assets, as well as any addition ones you have loaded.



Thank you Ross
i did scan the assets and nothing showed up. I checked the ./Reports/templates folder permission its accessible 755 (as suggested by Sandra here ) .

logs gave a successful run with zero count - - [03/Nov/2021:18:24:12 +0000] “GET /index_notification_ajax.php HTTP/1.1” 200 56 “” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36” “-” 0.013 0.012 .

moreover on local windows xampp install gave the same issue.

any other suggestions

Hi taha,

That’s great information, and sounds like you are doing all of the right things. A couple more suggestions a) is the folder /modules/Reports/templates/reports (which you’ve checked the permission of) populated with a range of .twig.html files, and some folders too? Do the permissions of these make them readable to your web server?

You mention another Windows install, but can you clarify what OS stack, and Gibbon version, you are running here?



Hello Ross
yes, the folder /modules/Reports/templates/reports populated with a range of .twig.html files, and some folders too and all with the right read-write permissions for my web server.

On windows 10, a local install is using xampp comprising an apache2-mysql-php7.4 stack . again with all permissions and the /modules/Reports/templates/reports populated with twig.htmls and folders.

I’m lost and started guessing (out of logic ) if there are somethings I’ve to do within gibbon reports module, such as creating reporting cycles in a cetain way. although I did that and I ran reporting and got blank pdfs with this line at the top “DRAFT COPY. THIS IS NOT A FINAL REPORT. 03/11/2021 10:39”.

so where to ahead now?


in both installs (Linux and windows) I used Gibbon v22.0.1 .
On Ammin > System Check , all indicators are green (OK), is there a specific php extensions involved with this scan of assets?

Hi Taha, this is rather unprecedented, and although we don’t test with Windows, on the Linux side we’ve been using Reports with a range of schools, and not seen this issue.

Above you mention logs, by which I think you mean Gibbon logs. Have you checked your PHP logs to see if there is anything there?


Hello Ross
finally out of this brain spin. :smiley: . Here is what happened.
I use a dockerized Linux-Nginx-PHP stack based on the light-weigth alpine distribution to save the resources. The problem with that is alpine is not compatible with the glob_brace function used by the asset scanner leading to useless path/ scan and nothing showing up.

Switching to Debian distro solved the problem but I had a terrible time getting the install page. It fell into an infinite loop of redirecting, till the server runs in a timeout.
It seems that the stack is not handling the gibbon.php director to the install page. Fixing it from the stack and the gibbon sides failed. Simply commented the directing lines and went to the install page on foot.(the stack worked perfectly with wordpress but i couldn’t copy the trick)

Another issue showed up may interest you that the vendor/tcpdf folder needs to be updated as the one shipped with gibbon v 22.0.1 carries a php7.4 deprecated array curly braces and falls into a fatal error with php8.

Thanks for ever-ready help


Hi Taha,

Sounds like you’ve had your hands full: glad to hear that you got it sorted.

The installer has been completely rebuilt in v23.0.00 (due out on January 20th 2022), although I’ve not seen the issue you describe before on Debian-derived Ubuntu.

Thanks for the heads up on vendor/tcpdf, which has gotten the update treatment in v23 too.