System Update Issues

I have just updated my installation to version 10 from version 9, but the update page still says i use V9 for that reason i’m not getting the database update dialog. Meaning i can see the new fields and updates around my site (from v10) but my database is stuck at v9. Is there a manual way i can update the database please…


That is really odd. In the footer are you seeing v9 or v10 listed? This is the version as listed in /version.php? Can you check that file, and make sure it is 10.0.00? If not, the file might not have been updated.

Basically, the version is stored in code and in the database, and the two are compared when it is time to do updates.

Lets check this before rushing into a manual update, which is doable, but might not be the best bet if there are other problems with the update, which the above my help us spot.



Ross u are absolutely right. I later discovered that some of the files did not upload. So i manually selected and uploaded them. I guess there was an interruption during the upload process. Things work fine now on my /primary install. But now i can’t log into the /secondary installation. :frowning:

Steve, good news and bad news! Tell me more about the failed login on /secondary. Is it an issue with your config.php file?

I don’t think its the config.php file because i always made sure not to overwrite it. It just says “Incorrect username and password.”

No one can log in either. Its as if i’m on another planet entirely. If it was a database connection issue i wont be able to see d homepage, right? Ive even gone through d database and cant see anything wrong there. Pls help

I updated my Gibbon installation to 10.0 and am also locked out. I am seeing the message incorrect username and password.

I run my system on the Amazon cloud one web server and another database server. So my database should be unaffected. Any ideas or guidance would be appreciated, I would prefer and hope not to do a whole reinstall.

I have verified my config.php file is still correct and unaltered for my database connection.

I tried requesting that my password be reset by the server. The server sent me a know password for my account, but i still can not log in?

Thank you

Now i can’t log into either /primary or /secondary. Where is the bug in the v10 update.

I am working to try and find a solution or work around. If i do, I will share it here.

I hope future upgrades go smoother, I had to delete and recreate my database! I am now up and running 10.0 and rebuilding my Gibbon system.

Thankfully I did not have it in full production and school usage. Perhaps soon.

I had to re-install my entire site last week and everything started working fine. But today i cant log in again. What is actually wrong and where?

Steve, dkerley03,

Sorry to hear about these issues. We did a lot of tests on v10 before releasing, and the updates we ran never had these issues. Neither have any of our other installs.

I am keen to find a solution to this ASAP (just got back from a road trip, hence the delay in replying to earlier messages).

If you are happy to share with me access to your FTP and database servers, I will take a look. Please share the details with me via Dropbox or similar service (avoid email!).