System not publicly writeable - System Check

Hello Team,
I am having a problem. Settings for site is at 755, I noticed one thing that everytime I add a unit or make changes in the planner the system check has one X mark on System not publicly writeable . I go and change the permission to 755 and do a save the tick mark appears. Is this a bug or something in my settings.

Hi paschal, on a POSIX system, the web server process has a user and a group, and this user or group needs to be the owner or group for the Gibbon files. I tend to leave the system user (e.g. admin) as the owner, and make the web server process (e.g. www-data on Ubuntu) the group. I then set to 775. Then I can FTP in as the user, but the web server can also write files. Hopes this helps! Ross.

Thanks ross