Successful Google Integration and Login Authentication Removes User Permissions

Hi, so I have just migrated from a local to a live server and went directly at trying Google Integration. I was successful on the google integration and was able to login accounts using gmail accts. However, I noticed that users who were able to login using their gmail accounts, upon redirecting to the dashboard, were not able to access pages and features. Upon trying to access pages outside the dashboard area, you will be redirected to the login interface with the welcome text replaced by

“You do not have access to this action.”

And one more thing, for successful login using gmail, the timetable area isnt loading. You can only see a loading animation.

Anyone have the same problem?

Hello, this is one I’ve not seen before. I wonder if you dump the user’s $_SESSION variable using print_r, what we might learn by looking at the various values in there. Want to share that with us? Just make sure it does not contain anything confidential. Cheers! Ross.

hi Ross, do you have a dummy or alt gmail account you can try at the website so you can see yourself what is going on?

Hi Ross, I got the problem solved. While it is true that i can successfully authenticate using gmail, I cannot access other features or i couldnt get to other web pages. The error message is “You do not have access to this action.”

For some weird reason, changing my absolute url from to worked like a charm. This is the same with an SSL certificate too as in from to

Hi beta, thanks for filling us in. I am glad to hear you got this one solved, and sorry I never got back to you on the dummy account.

It is odd that the www subdomain is making this difference, as it should not, as far as I know.

Cheers, Ross

Thank you, I had the same issue and adding www to the domain was the solution as well.