Submitting a behaviour incident is not working

When we are submitting behaviour incidents this is what is coming up on the screen.

Can somebody please help. This is the third day that this has been happening.

Thank you in advance.

Just trying to collect some background: is it when you try to submit the behaviour record? Does it always happen i.e. if you change the descriptor or +ve/-ve?

yes it always happens. I have tried changing students, descriptors, stages, with/without comment in incident box etc

Thank you for replying

Hi Tahseen,

It appears to be outputting php code rather than running it which is very odd behaviour. Could you visit the System Admin > System Check page and post a screenshot of the results? This can help determine if the problem is maybe in the server setup.


Hi Sandra,

Please find attached the results of the system check

Thank you,


Could anyone advise on this situation.
I’ve not seen any errors in the error log and also updated to 14.0.01 but same problem.

We have another installation of gibbon for test purposes, on the same domain, but don’t get that problem in that installation.

Hi athar1, this is really odd. It is as if it is seeing the PHP file as a plain text file, no processing it, and just returning the contents. Usually I’d suspect this is because the file starts with <? instead of <?php and your server has short codes turned off. But this is not the case.

Can you try and troubleshooting it by removing everything including and after the ? in the address and reloading the page. What happens?

Also, if you can check your file permissions on this file on the server and make sure the file is executable?

Let us know!


Thanks for getting back to me Ross.
I’ve tried removing everything after the ? - with no luck
The file permissions were all at 644 - I changed them to 755 and I had the same problem.

I’ve also noticed something else - don’t know if its a flaw in my system or something else. If i go to my default gibbon URL, it will ask me to login, but if I append that URL, with /modules, it lets me browse all the files in that directory. You can’t open the files, but it does let you see what files are in the directory.

I’ve restored the entire website back to one month ago and its now fine. Hopefully it doesn’t mess up again.

athar1, it is a shame we did not get back to the cause of the issue, as it would be good to solve it, but I am glad you are back up and running.

In terms of your second question, you most likely have not disabled director browsing within your web server. If you can let me know what kind of server you are using (Apache, Nginx, ISS) I can look into a solution for you. Thanks!