Staff import error


We tried to import an employee file and it gave the error as shown on screen 1 below. After that, we were no longer able to add a user via the system, displaying the error as shown on screen 2. An example of the import file is attached.

Thanks, Alessandra, Brazil.

Gibbon Versão v25.0.00
PHP Versão 8.1.8
MySQL Versão 10.6.5

tela erro import

Here is the error log from the moment of importing Staffs

Hi @espsc_tecnologia

This seems unusual, as it looks like there are over 4.2 billion records in that table. At least, that’s what the auto increment seems to be reporting, and has likely hit a maximum value for that integer type. Can you check the table itself and see how many records are in there? Otherwise, perhaps see if you can reset your auto increment value.

The values in your first column look quite long, are they usernames? I wonder if you may have tried to upload using the sync option, which may have attempted to insert those as gibbonStaffID values, which could have overloaded the integer value.

Thanks!! Now it´s ok!.

We manually changed the increment value and it started working again. However, we believe that there is a problem in the Staffs import module. After importing, this error occurred. When it returned to work the following appear in the Database Error Log:

SQL Error [08S01]: The last packet successfully received from the server was 51.050.427 milliseconds ago. The last packet sent successfully to the server was 51.050.428 milliseconds ago. is longer than the server configured value of ‘interactive_timeout’. You should consider either expiring and/or testing connection validity before use in your application, increasing the server configured values for client timeouts, or using the Connector/J connection property ‘autoReconnect=true’ to avoid this problem.

Glad to hear it’s working. This is an unusual error, it sounds like the file might have timed out while processing, however generally this would halt the operation and create a server error, rather than incrementing the values in this strange way. I will take a look and keep an eye on it. Out of curiosity, how big was your imported file size? Thanks.

Hi Sandra

The size of the file is 15KB.