Hi, I am very new to Gibbon. I am having problem with session.
I am not sure what happened here but when I tried to login, it says,
“our session expired, so you were automatically logged out of the system.”
This happens to all the users I created.

Advice is greatly appreciated

Hi bandhit,

Welcome to Gibbon! Does this happen immediately, or after a delay of some kind?

Please can you tell us what kind of server stack you are running Gibbon on?



Hi Ross,

Thanks you Ross,
No it does not happened immediately, actually it was working fine for hours but then just happened.
I think the administrator has Linux set up .


Hi bandhit,

Welcome to the Gibbon community :smiley: What you’re seeing is likely a feature rather than a bug. User sessions will be timed out if they’re inactive for a certain length of time, to ensure that someone else can’t open the device and use the system. Especially useful for schools where teachers are constantly on the move and using different devices.

Hi Sandra,

Thank you. I think it might relate to “Session Duration” in System setting which I tried to change from default value which is “1200” to more but did not pay attention to detail about “Should be less than PHP’s session.gc_maxlifetie”
but I seem to have the back up of the DB so I rolled it back and it works again.

Ah, that makes sense. Having a setting of more than session.gc_maxlifetime will mean that the session life is shorter, on average than Session Duration in Gibbon. You can always increase session.gc_maxlifetime, reload the server config (e.g. sudo service apache2 reload in Linux) and then update Session Duration in Gibbon if you want a longer session. Cheers! Ross.