Search Function Not Working

Function not working since latest update.

Hi @amcguigan It’s hard to tell what’s up at first glance.

  • Is it intermittent, or 100% not working for every user?

  • Try a more common letter like A or E, do any results come up? There should at the very least be Actions in the list.

  • Try logging out and back in again. Does it still not work? (If your login session times out the search functionality will stop working until you log back in)

  • v13 switched the FastFinder to an AJAX function (also Javascript). Try going to Home in Gibbon, and then edit your URL to change index.php with <code class="CodeInline">index_fastFinder_ajax.php?q=a. You should see a page with a bunch of text on it (the search results), otherwise it may be a permissions error, or the AJAX requests are being blocked somewhere between the browser and the server.

This warning came up.

Warning: date(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone

This has come up a few times are logging in also.

Hmm, very odd. When you updated Gibbon recently do you know if you server’s PHP or MySQL versions were also updated? This is sounding like a system setting/version change, and may somehow be related to the messenger error too.

When you go to Admin > System Admin > System Settings, what does the Timezone setting display as? Also can you check Admin > System Admin > System Check and post a screenshot of the results?

Timezone = Asia/Tokyo

Okay, those settings all look good.

As helpful as the warning message is, generally on a production system one wouldn’t see any warning messages (they’d be turned off in the php.ini file). If the warning message is superceding the AJAX results this could mess with the search function. If you’re willing to test something, try adding these lines to the very bottom of your Gibbon config.php file to suppress error messages:

ini_set('display_errors', 'Off');`

Otherwise, that's my best guess so if that doesn't work it may have to wait till Ross is back from break.

(PS: "Just turn off the errors" isn't meant as a long-term solution, just a diagnostic step. If it turns out they are what's conflicting with the AJAX calls then we would work to fix the source of the warning messages for the next version. However, generally in production your php.ini file would be set to log the errors to a file but not display them).

Sorted. Thanks for the support.