Rollover SQL error

Hello wonderful community,

I did a rollover and encountered this SQL state error:

and after the rollover the students were scattered unevenly to different rollgroup while some missing, what could be causing the above error.

I had my backup and currently trying to rollback to retry the rollover again.
running Gibbon V21

Thank You in advance

Hi Kelvin,

That’s an interesting error. I’ve tested v21 on this end and haven’t been able to reproduce the same error. In theory, the gibbonRollGroupID field shouldn’t ever be null, because the roll group is a required field for each of the enrolments on the previous step. I wonder, when doing the rollover, had you already setup the roll groups for the upcoming year? If so, they should have showed up as dropdowns next to each student, which would have theoretically ensured that gibbonRollGroupID isn’t null:

I wonder if you’re able to share some steps to help reproduce the error, including perhaps a screenshot of the previous step before submitting the form (with any private data blanked out). If it does look like there is an error in the rollover I’m keen to get to the bottom of it.


The above error keeps on appearing even after trying backups and repeating the same process and also tried several search for the error.

I have setup the next rollgroup as required:
we have two section of the school and one section with 75 students rolled out perfectly but the section with slightly above 600 students is where I am getting the above error.

The only difference in the two rollover is that I have included a new rollgroup for the next academic year and mapped it correctly to the current rollgroup,

we have not manually modified the database its is all intact as generated from gibbon install.

Thank you.

The first student:

The last student:

Ah, In that case, I think it sounds like a PHP resources error. You may need to check and increase settings like max_input_vars and post_max_size to ensure that your server isn’t exceeding it’s built-in maximums for submitting form data. There’s a couple ways to change these values. If you have access to the php.ini file on your server, this is the most guaranteed way to change these values. Otherwise, you can add them to an htaccess file or even at the bottom of Gibbon’s config.php, examples below, but it depends on your server configuration whether it honours these settings:

.htaccess example:

`php_value max_input_time         10800
php_value max_execution_time     10800
php_value max_input_vars         7000
php_value post_max_size          128M`

Bottom of config.php:
`ini_set('max_input_time', 10800);
ini_set('max_execution_time', 10800);
ini_set('max_input_vars', 7000);
ini_set('post_max_size', '128M');`

Thank you very much, earlier I had increased input to 8000 rather than 5000 and I was still getting the error…

let me try that and update you. Fingers crossed ; I hope it works :wink:

Thank you again.

Hope it helps! After making changes to php.ini, be sure to restart your server to ensure they take effect.

It has worked perfectly <3 :slight_smile:

Thank you so much again @ross

I have literally shouted like yeekks!

Great to hear! :smiley: