Reporting module. "Oh no! error!

Hello everyone.

I’ve been setting up our school and i have tried to add the reporting module.
Everything went well until I tried to make a report.
Once I hit “Make PDF” all I get is the “Oh no!” error. I was thinking that the next session where I can write the report.
Once I go back from the “Oh no!” I can see that a report has been made and I can download it, however, with no inputs or information, it’s a blank report apart from the Criteria that I pre-set.
I am using Gibbon V18. I’ve reinstalled the reporting module twice, just in case it was an error while installing

Is anyone else having this problem?
Any advice on this problem?

Thank you all.

Can you paste the url you get when it shows “Oh no!”?

Before you start creating reports you have to finish the configuration, e.g. assign year groups and create the report design.

Once this is done you need to enter scores and comments. This is normally done by the teachers using “Reports-Pastoral” and “Reports-Subject”.

Hello meierrom.
The link

I have checked that i have set up the school report, year groups, report design and gone and tested the creation with entering a test data, with marks.
I still get this Oh no error.

Yeah, it’s a known bug, which can easily be fixed.

Can you see the double forward slash in the URL? Instead of “modules//pdf.php” is should be “modules/Reporting/pdf.php”.

Maybe you can try to do the correction yourself? If not, what version of the reporting module are you using?

Hello Meierrom,
Thank you for your reply, Now you say it, I can see the error. Its looking for another folder with no name.
I could try to correct it myself but what file will the error be in so i can try to change the file?
The version of the reporting module is v2.16 with gibbon v18.

Many thanks

Filename: pdf_create.php, line 176

While you are ad it, comment line 32, which is no longer needed.

Thank you!! :wink:
That did the trick. All is working fine now.

Thank you so much for your help.


Your welcome :slight_smile:

Hi @BrianE and @meierrom glad to hear it’s resolved. @andystat just released v2.20, which is now live on our Extend page…but I’m not sure if it fixes this issue or not. Ross.

Dear Admin ,meierrom ,

           Its not working on PDF Creation . Please look into it.

@andystat any input here?

@ghulamabbas92 which version are you using, and what error messages are you getting?


Upon clicking Create PDF it remains loading and then stops.No Message appears

In the module menu is there an Archive option? I think the latest version saves the PDF into the Archive, from where you can retrieve it.

@ghulamabbas92, which version are you using?


It gives error after loading when create PDF is clicked

Can you share the PHP error message with us? Thanks!

There is no error in error log only this white screen appears and also there is nothing in Archives

Is there anything in your error log file? Often errors are set to not display on screen (so as not to upset users), but it should be logged.

I have checked the error log file but there is nothing in it. Have you checked it on your own system?