Problem migrating to new URL

The school whos system I am managing has recently changed its name and consequently it want to change the main URL for Gibbon from to I have made this change via the admin portal but still get the Apache 2 Ubuntu Default page if I go to I can tell that something has happened because now doesn’t work. Have I done something wrong here or do I just need to reboot the web server to ensure the changes propagate through?

Correction: I meant base URL instead of main URL.

Hi sdbaldwin, if you’re changing the domain, the server and DNS will also need to change. Be sure to check the IP address of your server and then do a host lookup to see if this new domain resolves to the correct IP address. Also, internally you’ll likely need to update any SSH certificates to match the new domain, check your Apache sites_enabled settings to change the default domain handler, and your /etc/hostname file. Hope this helps!

Sandra, thank you so much for getting back to me. I have only just managed to regain SSH access to the host as the IT support company had changed the settings when they migrated and have only just been able to let me back in. The IT company have already changed the DNS to point to the host instead of the old Unfortunately I changed the base URL from within the system admin section of the website and so now it doesn’t work with either!. When I navigate to I still get the Apache2 Ubuntu Default Page instead of the Gibbon login page. I have fixed similar issues before on an older Gibbon version but just cannot remember what to do(too much heavy food over Christmas!). My /etc/hostname file just has the name of the host VM instead of the website URL so doesn’t need to change. What config files do I need to change to get this working again? Thank you so much in advance…

OK, so I thought I’d “found” the solution to this from one of my old threads (my memory is a bit flaky at the moment) and I used the advice in there to access the MariaDB database and change the absoluteURL to I rebooted the host hopefully but I still have the same issue:

  1. still gives the Ubuntu Apache default index page instead of the Gibbon login page.
  2. still shows the Gibbon login page but login doesn’t work as the new base URL is Pressing Login links it to which then throws the error: “This page isn’t working is currently unable to handle this request.
    HTTP ERROR 500”

I am clearly missing something important but I am stumped, has anyone got any suggestions?

Thanks in advance…

At the moment the /etc/hostname file contains ois-lms `(the name the external IT company gave the Ubuntu 18.04 host that they set up for me)

`The /etc/hosts file contains: localhost ois-lms

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters`

Currently both and both point at the host, not sure if that could cause a problem.

I found the solution. It was to modify the gibbon.conf file in /etc/apache2/sites-enabled

This is what you suggested I did Sandra in your post but I had to get my head round it! Thank you so much!

Glad to hear you got it worked out! Lots of moving pieces in a server migration. I also find there’s always something I have to learn or re-learn when I do a migration because I do them so seldomly.