Planner Error Message

I´m checking a teacher´s planner that is connected with a homework (the one that relies from a student account when a student wants to upload), when I move down it appears the following message:

What does this message mean?, I have no idea.

Adolfo this kind of PHP warning, which is not an error, but something less serious, should be disabled on your server in order to avoid this kind of error in a production system.

@skuipers, I’ve looked at the file in question, and adding date_default_timezone_set($_SESSION[$guid][‘timezone’]); to the class constructor should do the trick, but I am wondering if there is a more elegant solution that you might have in mind. I notice the timezone is not set in any of the other files in /src, so just curious as to what the best approach might be.


Yep, incidentally this is already fixed in v14, the date_default_timezone_set() is in the Locale class constructor, and we removed all the extra calls to it from other files. For now, disabling the notices should fix this for the particular case.

Is it perhaps worth forcing display_errors to be off in any Production system (via the setting), since there’s no good reasons to have it on, and plenty of good reasons to have it off.

Upps, chinese for me, really dont understand what are you talking about, Im not a programmer.
Now, what should I do? Ross you said to me I have to disable this message in my server, how?

Adolfo, the best bet is to speak to your hosting support and ask them to set display_errors to off in PHP. Ross.

@skuipers that’s right, you did fix that issue!

You could try placing @ini_set(‘display_errors’, 0); at the bottom of your config.php file, before the <code class="CodeInline">?>. This may save the trouble of having your hosting make changes to php.ini for you.