Hello All,

I just create a new role and tried changing permissions ,When i did so logged in as administrator it told me that i didnt have permission, now it looks like I dont have admin rights at all to the system.

Can someone help me with this?

Hi, that does sound potentially serious. When you submitted the Manage Permissions form did you see any error messages, or did it appear to be successful? Does this appear to just be affecting your role or all users?

A couple steps you could take at this point:

  • Check your server’s PHP error logs to see if there’s any recent errors
  • If you have access to your Gibbon database, check the gibbonPermission table

When I submitted it said I do not have permission for this action. Or something like that. Not seeing any errors in the log, I have access to the database, what should i be looking for in the permission table?

Hi Sandra, You suggestion of taking a look at the permission table gave me the Idea of deleting everything in that table and uploading one from another install. IT WORKED! Thank you. :slight_smile:

Glad to hear you were able to restore your permissions. I wonder what may have caused the problem, it’d be great to know what’s up so we could ensure it doesn’t happen again. For now, perhaps take a backup of your database first the next few times you make changes in Manage Permissions. That way if it does re-occur you’ll have a recent backup, as well as we could compare the tables and see what’s up.


@ross I suspect when someone is updating the permissions for some reason the script times out before saving everything on the database. That has happened to me many times.

Hi James, that is really interesting, as I’ve never had that issue occur before, and it usually takes only a second or two to load…even with many roles and additional modules. I’m curious to learn more about your server config…

This happened to me again and i forgot that i posted this issue. Sandra I’m going to erase the table and redo the steps so you can compare.

Okay, let us know what you find. Also be sure to check your PHP logs for around the time this happened to see if there’s any clues in there.