Office 365 Integration

I was doing a search how to integrate Gibbon installation with Teams, and suddenly version 23 notification popped in… :smiley:

It sounds very promising, but there is no documentation about it…

I tried activating it, enabled API but its on login loop.

Second, I have staff and students who have Azure ids, will it be possible that Gibbon and Azure ids can be merged? (I am using the same userid as login for gibbon separately :: just to be clear, without any sort of integration enabled…’s userid i create for gibbon user, and their is their contact email.

Hi Sam, thanks for the heads up, it’s a brand new feature and we’ll work on updating the documentation.

To get started, be sure to login at then go to Azure Active Directory | App registrations to create a new app. Once you’ve created it, you’ll be able to access the Application (client) ID as well as create a Client Secret. Copy these and paste them in the relevant fields in System Admin > Third Party Settings > Microsoft SSO. You’ll need to copy the Redirect URI from Gibbon and register it back in the Azure application under Redirect URIs.

Hope this helps you get stated. For the login to work, the email for users in Azure will need to match the email for users in Gibbon (and will need to be unique in Gibbon).

Hi Sandra;

Well, I followed all the steps, but for sign in, it goes on loop, like after i sign in my test account, it goes back to the login page…

Hi Sam, have you registered the Redirect URI with the Azure side of the authentication loop? If so, I wonder if its returning an error that we’re not seeing. Can you check your System Admin > View Logs for any login failures, and expand them to see if a reason is provided.

Sorry i missed your reply :slight_smile: a lot of dishes i am cooking so skipped that one… I will check that later today and let you know…

Hello Ross,

I had the same problem with the poster, It is keeping a loop, and refreshing the page.

Kind regards,


Hi Butters, have you tried Sandra’s advice of February 7th, in the post above? Ross

Hello Ross,

I just managed to access Gibbon by Microsoft login. But TBH, it is not easy to log in, and it is having the chance to go loop. I guess it is because of the cookies? I guess it also comes through the problem with the Microsoft function when Microsoft always asks you to keep the login status most of the time. I am not sure what exactly part caused it.

Sorry, I am not the developer, that is the only thing I could provide for you.

Kind regards,


Hi Butters. I haven’t found that the redirect goes in a loop when fully configured, so I wonder if it could be local cookies, you could try clearing them and check. Be sure to also double-check that the redirect URL is correct and doesn’t have any extra characters or spaces.

Microsoft asking to login again is unfortunatly something outside our control, as it’s part of their storage and management of cookies for SSO purposes.

Hi Sandra;
I uninstalled Gibbon on my system due to this very problem. I am beta testing your new version (24.0) now. I reconfigured everything again. and still the same problem (at this time i am using chrome, but will check on other browsers if the same problem exists). and yes, the problem is same in all browsers.

Hi Sam72, have you checked to see that your redirect URL is registered on the Microsoft side, as it won’t redirect properly unless it has been registered. Otherwise, please see if you can check the PHP logs as well as the View Logs page in System Admin, if there are any specific errors in the OAuth process they should generate a log that could help us identify the issue.

okay i will check it out

I rechecked all settings, reset the configuration, and tried again, same error. in System Admin, View Logs, I see no information about OAuth process.

I’m having the same problem too, but I realise that it is redirecting to this error URL:


I don’t know if this helps at all? Many thanks,


Okay, I’ve followed this up and got it working now.

  1. Go into Azure > Azure Active Directory > Your Tenant.
  2. Select App Registrations > Gibbon > Authentication.
  3. Scroll down and change ‘Supported account types’ to ‘Accounts in any organizational directory (Any Azure AD directory - Multitenant)’.
  4. Click Save.

Not entirely sure what is going on, as I only really want users of my tenant to be able to access it, but it may be something to do with Office 365. Anyhow, it’s a way forward. I found this solution here:

Many thanks,


Thanks for sharing your solution! Glad to hear you got it working.