New Theme

Hello again, Gibbon!

I am working on creating a company theme but am running into trouble with the final step. I have copied the Default theme and renamed it, then updated information in the manifest.php document.

The new theme is in the “Not Installed” list in orange. When I install it, though, I get a message that the theme was installed but it doesn’t move into the “Installed” list with my Default and Legacy themes. I tried checking permissions in the themes folder and that looks fine (I even changed chown to www-data in case that was an issue). I assume there is something basic I’m not doing, but I could not find documentation on how to solve the problem.


Hi Kevin,

I just tested it locally and it seemed to work. When you updated the manifest, does the $name variable match the name of the folder? As a test, I duplicated the Default, renamed the folder, changed the $name to match, and it worked. Be sure, in changing the manifest, that there isn’t a syntax error such as a missing " or ;

Hope this helps!

The name issue was actually my first realization, Sandra. When I initially copied the Default folder I forgot to match the names and didn’t even get an option to install my new theme. (It showed in the “Not Installed” list but was red and didn’t have the + button to install.)

Your comment about syntax, though, did get me thinking about the one change I made to the manifest. When I changed the name and author information, I commented out the $url variable with /* */. (I don’t have a website attached to my theme but didn’t want to lose the variable in case that changed.) Once I opened that variable up again, everything moved forward.

For now I will just put a placeholder website in there. Should I delete the variable if I don’t need it, or is there a different way to comment it out?

Thanks again!

Hi Kevin, great to hear you got it working. For the $url variable, feel free to set the variable to an empty string, $url = “”;` (rather than commeting it out) and this should work.

That worked great! Thank you so much, Sandra.