MIME type issues when uploading CSV file through data admin

I’m trying to import a CSV file containing course information, however I receive this error:

Import cannot proceed, as the submitted file has a MIME-TYPE of application/octet-stream, and as such does not appear to be a CSV file.

This happens when using Firefox, Edge, Chrome and Midori.

I was getting a similar issue with importing a CSV containing timetable info (complained that MIME-TYPE was plain text). I found a couple of solutions:

  • opening it in notepad and then saving it in ANSI encoding with a .csv extension
  • using Save as from the File menu of excel to save as a standard CSV (not UTF-8)

Hopefully the same fix will work for CSV imports in the Data Admin module!

Hi vktec, the advice on the following support pages is more directed a Gibbon’s core imports, but might help in terms of Data Admin as well:


@ross might have some further suggestions.

@Dorian thanks for the input : )


Hi @vktec and @Dorian

Thanks for the heads up! I’ve added application/octet-stream to the list of allowed mime types in Data Admin.


I am getting the same problem trying to upload student photos. Any ideas?

Here is a screenshot:
The file I tried is this: removed for privacy reasons.
I also tried zipping it but got the same error.

Hi vlaoic, the image is rather big (should be 320 x 240px), and so perhaps this is causing the error, and the error message is wrong. Please can you resize the image, and email it to support@gibbonedu.org. I will then ZIP it, test it on my system, and email to you for testing. I am going to delete the image above, as it might not be something the parents want on a public website. Thanks, Ross.

I did my resizing in photoshop and followed the size given in the interface. I just reduced it to the 320x240 and got the same error as a .jpg or zipped .jpg. I will try some other formats to see if I can get anything to work. Could this be a problem with my server setup? Everything else seems to be working OK. Thank you Ross (emailed you a test file)

Maybe I am misunderstanding the process using Admin>USer Admin> Import User Photos. I have no problems importing the same file that fails in: Home > User Admin > Manage Users > Edit User > User Photo

Thanks for the email. I’ve replied. To be clear, the image works in Edit User, but not in Import User Photos, is that right?

I was making 2 errors. 1. The image must use the user name , and 2. .rar and zip are not the same… must use .zip… I did not know this. Thanks for troubleshooting for me and feel free to remove these posts!