Migrating from Local to Registered Domain

Hi, I seem to be having problem in migrating the system from local server to a new domain. Have uploaded the files and tried to recreate the db, had edited the database absolute url pointing to my domain. However, I am not sure what to put in the base url. I am having error 500. Anyone who have had encountered this before? Thank you

What i mean is the base path. I have edited the base url to http://mydomain/gibbon

However, I am not sure what to put under base path. Is this the same?

The base path is the absolute path where you keep your Gibbon files.

It corresponds to variable absoluteURL in table gibbonSetting.

An example could be /var/www/html


Thanks @meierrom finally got to set the base path and base url.

I did a fresh install on the new domain and I was successful. Pretty sure now I got the db settings correct as well as the base url and base path.

Going back to my migration from local to the new domain, i always seem to get an internal server error. I uploaded the files. Edited the config file. And edited the database base url and base path.

Im sure i had the correct the config file settings as well as the base url and path.

What could be causing the error?

What I did, since I had the fresh install working, itried to import my db from local and it messed up. So I assume it has something to do with my db from my local server that is causing the error.

By the way, I noticed that fresh install of gibbon to my domain has naming convention as “gibbonSetting” whereas the naming in my local db is “gibbonsetting” these applies all to table names such as “gibbonPermissions” as to “gibbonpermissions”. Is this perhaps the reason why I couldnt migrate?


The database table name case issue does sound like an issue, as most MySQL installs (in my experience) are case sensitive.

Other than that, 500 Internal Server Error is most often caused by a misconfiguration of the server, but some servers report 500 instead of a PHP error. Can you check your PHP logs to see if there are any hints there? In addition, can you set up a phpinfo page, and see if that works? That can help distinguish between general server issues, and Gibbon-specific issues.



Hi, thank you for the reply. I have checked and it is not actually a general server issue nor a gibbon specific issues. Not a gibbon specific issue since i am able to execute the error page “Gibbons have escaped” by purposely setting the incorrect config settings. It is not also a general server issue as I was able to connect to my db when I tried a fresh install.

Although I was able to run the system at my local server and i was able to prepare it for uploading to an online server, the problem is that the generated tables in my local database for gibbon are all converted to lower cases such as “gibbonsettings”, “gibbonpermissions” etc. This has no negative implications running locally as I am on Windows and it can run not specific on the cases.

The problem will be on migrating online as I have just experienced. It runs on Ubuntu and it is case specific. I have made sure the config file is correct so it can connect on the db. I have also checked that both the base url and path are correct which by the way should still be able to show the text in the login page regardless if both base url and path are configured correctly. This is because a correct config file with misconfigured base url and path will still be able to load at least the texts in the login page but of course without the expected proper layout and not an internal server error.

I have checked the logs and it showed signs that it couldnt find the specific table. And this is perhaps the reason why I was getting the internal error as the system will have problems processing the session.php because it couldnt find the specific table in the database because of the lower case issues.

The system is running okay now in my new online server. What I did is to use the generated table (with case specific table names) of a fresh install and populate it with data from my local database which of course by using the query

INSERT INTO freeLearningUnit xxxxxxxxxxxx
instead of
INSERT INTO freelearningunitxxxxxxxxxxxxxx

For guys who are testing using WIndows/WAMP a fresh install will convert the database tables to lower case as the default value in lower_case_table_names = 1. You need to change the value in the my.ini file to lower_case_table_names = 1 to prevent changing tables to lower cases.

Thanks for sharing such a thorough description, as well as the solution. Very useful to have this documented!

There was a typo

lower_case_table_names = 0 for unix and lower_case_table_names = 2 for windows.

If you are using xampp set lower_case_table_names = 2