Markbook Export Failing (zero byte file)

I just tried to download my Markbook using the Export to Excel button. I ended up with a file with a zero bytes file size (that obviously cannot be opened). Looking in some other places, I’m getting the same result with excel downloads from other places (such as the Data Admin formatting sample and the individual assignment scores export). I do not have this problem with PDF files from the Reporting module.

Any ideas?

Hi Ernest, this one is interesting, and I suspect that there will be some clues in your PHP error log. I believe you are using a hosted server, in which case you may need to ask your host to share the log file with you. We can then take a look at it for you to try and find out what is going on. Email the log file to when you have it!

Is that the Log file in my ~/Logs folder? I have something called gibbon.[mydomain]-Oct-2018.gz and something called gibbon.[mydomain]-ssl_log-Oct-2018.gz.

Yep that could be it, the location of log files can very from system to system. The .gz means they’re gzipped, are you able to unzip them and take a look at the logs? Otherwise be sure to email log file to

I’m going to go ahead and email the two zipped log files. Thanks!

Ok! After some guidance via email and some digging (as well as some time with this on the shelf as I dealt with other things and took a trip home), I finally found the relevant log! And every error line is the same.

[26-Nov-2018 13:37:44 Asia/Taipei] PHP Fatal error: Class ‘XMLWriter’ not found in [Path to Gibbon Removed]/lib/PHPExcel/Classes/PHPExcel/Shared/XMLWriter.php on line 44

Any ideas?

Hi Ernest,

Are you running the latest commits of v17? The PHPExcel library has just been moved from /lib to /vendor, which could explain that error. I’m not able to replicate it however.