Integration with Moodle

I’ve followed the steps outlined in Marks questions.

I cant see the db table moodleUser although I have installed the module.
I tried gibbonPerson but to no avail.

I am getting the following error message:
SQLSTATE[28000] [1045] Access denied for user ‘onlinet4_gibb227’@‘localhost’ (using password: YES)
Fatal error: Call to a member function prepare() on a non-object in /home/onlinet4/public_html/gibbon/functions.php on line 3500

Could you offer any sugestions?



Let’s see if we can help. Please can you let me know the version of Gibbon you are using, as well as the version of the Moodle module.

Can you let me know the steps you have taken in installing the module?

Also, when you see the error message above, what page are you seeing it on. Can we get a screenshot shared here?



Hi Ross and thanks for your prompt reply.

I installed Gibbon v11 via Softaculous on Siteground (Made the DB web accessible to allow Moodle to connect to it).
I uploaded the Moodle module v1.0.03 via ftp and confirmed that it was there on refresh via the GUI.

I added the details to moodle (Screenshot below) following the instructions located here.

The instructions specified a Table named “moodleUser” but that didn’t connect.
I jumped into the gibbon DB via navicat and saw that there was no usertable named moodleUser but there was a table named gibbonPerson so I tried that.

The below error occurs when I try to visit the site
It’s blank with only the following message.

The connectionSQLSTATE[28000] [1045] Access denied for user ‘onlinet4_gibb227’@‘localhost’ (using password: YES)
Fatal error: Call to a member function prepare() on a non-object in /home/onlinet4/public_html/gibbon/functions.php on line 3500

Update: I got it working with the version v1.0.02 Moodle Module.

It’s looks amazing and I’m enjoying playing with it.

Thanks heaps,

Verz, glad you got it working. What did the trick in the end? I was wondering, reading the post, if you had dropped the module in the right folder, but then not run the install script under Admin > System Admin in the main menu and then Manage Modules in the module menu. This would account for their not being the relevant tables (in fact they are views not tables, but they act like tables for the most part).

I followed those steps but it could have been a few different things. Seems to have been the Moodle mod but that may not be the case - still playing.
Once I get the steps down pat I’ll post them if it’s helpful. I’ve built and blown away the installation a few times for testing so hopefully will have some clearer info then.

For context:
I’m actually looking at this for a small Australian college of 140 students so am seeing if I can setup/modify it enough to be fit for our purpose. (Mostly renaming some of your terms: “Spaces” will be changed to “rooms” etc.
It’s been fun looking up the vocab like “Forms Groups” and “Houses” :smiley:

It’s an amazing piece of software and I really appreciate all the work you/you folk have done.



Excellent, thanks. I don’t use Moodle, and have not tested the module in a while (beyond checking that it works on Gibbon in terms of installing properly). Anything you can contribute would be much appreciated.

v12 has a custom string switcher built into System Admin, so you can change Spaces to Rooms without coding. In fact, Spaces has become Facilities in v12 anyway, which might be more to your taste (been meaning to change that since v5 : )

v12 is due out June 24th, but I think it might drop a little early. Have you joined the mailing list to get release notifications?

Thanks for the positive feedback, good luck, and keep the questions coming.


Hello @verzog , Can you please make a tutorial video on how to correctly integrate Moodle with Gibbon. I have been longing for someone who can assist the community members in doing that as most of the members (including me) are not programmers. So any step by step guide from you will be really very much appreciated.


I have just got this working with the lastest Moodle.

I had to change the password format to MD5 hash. Basically if you leave that at internal it defeats the purpose. MD5 says that password is stored in the gibbon database and that it is stored as MD5. Internal means moodle maintains a separate database for passwords. I hope that helps.

I also used gibbonperson for Table and it connects.

@cfoster thanks :smile: I will try this and see if it works out for me :smile:

I have done some more testing and this is what I have found.

  1. Moodle only support passwords in MD5 format. If you have installed the test data in gibbon all the passwords are stored in the database under password in MD5 format “gibbon” this means you can login to moodle with username 1520 and password gibbon.

  2. If I login to gibbon with 1520 and password gibbon I can log in BUT as soon as I do that the password changes in the gibbonPerson table to SHA256+salted and stores the password in password strong. Then moodle can’t log a user in because 1. the password field is now blank and moodle doesn’t support sha256 only md5 salted.

Unfortunately it seems integration with moodle would only be possible IF passwords stayed in the MD5 format (moodle can handle salted MD5 even) but I can’t see any support in moodle for SHA256.

@admin Ross can you confirm what I have said makes sense?

@cfoster, you are right about Gibbon and the way it works. From (distant) memory, however, I think you can choose in Moodle to synchronise from Gibbon, but store passwords in Moodle, just avoiding the problem. I think! Sorry, I am not a Moodle fan, or expert: the module was built as an experiment but has not been maintained or tested a great deal since initial release. It definitely did work, but then Gibbon used to store passwords with MD5, so maybe our security improvements broke it? I do think I tested it once post-SHA1, and it worked…check out the idea above and see how you get on. Ross.