Insufficient permissions to login

I’m currently setting up Gibbon for our language school.
I’ve uploaded all parents and a test teacher, assigning a primary role and “roles” to all (for most it is “parent” in both case).
I’ve tried logging in as a parent and as a teacher and both times I’m being told that I do not have sufficient permission to do so.
The password fields weren’t left empty in the file and I requested that all users be asked to update it on first login.
Am I missing something really obvious?

Thanks in advance for your help.

After reading further threads on the forum, I’ve worked out that it is because the field “all roles” has no selection (although the data was input in the csv file). Is there any way to update this in one go for all users within the same primary role group? Or any way to get this data to import in the first place?
If anyone has any idea/suggestion, I’d be very grateful.


Are you using the built-in user import, or the one from Data Admin? If it’s the latter, the issue should be fixed in the most recent version for v16 (v1.3.07). If you replace your current module with the update you can re-run your import using the Update Only option to fix the All Roles field. Otherwise, you could try the following SQL to fix it in one go:

UPDATE gibbonPerson SET gibbonRoleIDAll=gibbonRoleIDPrimary WHERE gibbonRoleIDAll IS NULL OR gibbonRoleIDAll = ''; `

Hope this helps!