Installing v23 - stuck at step 4

After installing v23, I’m at /install.php?step=4. Clicking on go to your Gibbon homepage does not take me anywhere as would happen before - just stays on the same page. Clicking on the logo did take me to the home/login page.

Hi Tieku, thanks for reporting this. We tested the install many times during development and release, and do not encounter this. To help us try and work out what is going on, can you let us know what you get if you right-click on the link and copy it? Paste the result here, and compare it to what you get when you do the same on the logo? Thanks! Ross

Hello Ross,

After installation, this is what I get when I copy link address:

Link address for go to your Gibbon homepage link:

Link address for logo:


Hi Tieku, that is very odd. I’ve just run a fresh installation of v23, and then link worked as expected. What versions of PHP and MySQL are you using? What is the OS? Has this happened multiple times, or just once? Thanks, Ross

Hi @admin same error experienced by me for php 7.3.33 mysql 10.5.12 shared hosting.

@admin it has happened on two separate installation attempts.

OS: Linux (Debian) 9

Thanks @ghulamabbas92 and @tiekubd. It looks like you are both using MySQL 10, which I think might actually be MariaDB. Can you confirm this? Are you able to try MySQL 8 to see if that works?

My server supports MariaDB 10.2 - 10.4. No MySQL.
v22.0.01 installs worked okay.

Hi Tikeu, the whole installer was completely refactored by one of our volunteers (Koala) during v23. I’m going to see if he can look into this. Hold tight!

Hi Tikeu,

Let me take a look.

Do you happen to leave a copy of the Step 4 html code? If so, that would be hugely helpful. Thanks

Hi Koala,

Are you asking me for a copy of the Page Source?



@tiekubd: I’ve just submitted a PR here to fix the problem:

Brilliant, thanks for this Koala. The fix looks good to me, and I’ll leave it for Sandra to review and merge.

@tiekubd and @ghulamabbas92 , do you want to test the change to install.php in the above pull request on your copy of Gibbon to see if it resolves the issue for you?

I can do that. I will let you know.