Installation on CentOS 7

Hi there,

I have so far installed Gibbon on windows (XAMPP) successfully with no issues. I am now attempting to install and test this on a CentOS 7 VM (running on OSX host). I have installed the LAMP stack with no problems (PHP 5.6) and can successfully access a temporary index.htm file and info.php in /var/www/html folder. I then unzipped gibbon ( in /var/www/html/gibbon and set the permissions to 755. apache:apache owns all content /var/www/html/*.

When I attempt to access http://ipaddress/gibbon, I am not getting the installation page. Apache log /var/log/httpd/error_log has the following error: PHP Fatal Error: Unknown: Failed Opening Required ‘/var/www/html/gibbon/index.php’ (include_path=‘.:/usr/share/pear:/usr/share/php’) in Unknown on line 0

I upgraded my PHP to 7 (including dependencies) but got the same error. I would greatly appreciate any assistance.

Is there a step by step guide for installing Gibbon on CentOS? I am not able to find any on this forum.



Interesting situation. I wonder if it is a misconfiguration in PHP: I’ve not used CentOS if 4 years, but I remember it being much harder to get right than Ubuntu (my own preferred Linux distro).

Have you tried creating a phpinfo page to see if PHP is working as expected? Use the link below to see how to do this:

Let us know if this reveals anything.



PS, it’s not possible for us to do guides for every individual Linux flavour…and really we don’t see our documentation covering OS setup any way. We have a XAMPP guide as someone contributed it to us…but generally not our area. Happy to try and troubleshoot though! Hope this makes sense.


Thank you so much for your quick response.

Here is where I am now. PHP works fine (PHP 7.0.9). The info.php file also works and displays all the PHP parameters.

I am now able to get to the installation page ( I was missing the following command) sudo setsebool -P httpd_enable_homedirs true. I think this was what was causing the error I reported in my first post.

Now, this is the new error I am getting at the installation page: “The directory containing the Gibbon files is not currently writable, or config.php already exists in the root folder and is not empty or is not writable, so the installer cannot proceed.”. This is despite the fact that I have the /var/www/html/gibbon permissions as 777. I have also tried 755. I have attached a screenshot. Appreciate any assistance in debugging this.



A quick update. I was able to successfully install and test the system. The issue turned out to be further SELinux permission restrictions on httpd. Specifically, I had to set the following: sudo chcon -R -t httpd_sys_content_t /var/www/html/gibbon I hope someone else will find this useful - it sure took a lot of googling and reading. Note: with this setting, 755 permission on the gibbon folders/files works as you specified.

Thank you again Ross.

  • Yonatan,

Yonatan, well done for solving this issue, and for sharing the results with us. I am sure this post with help others in the future. Good luck with Gibbon, and feel free to start new threads as and when you need help. Ross.