Importing Users

So… after trying excel and Libre Office i am still unable to bulk import users using the .csv format. Made all the checks, required information is present, top row removed, save correctly. When i import the users it states “The database was successfully locked” in green. Underneath in red " User with username had some information malformations" and “No useful users were detected in the import file (perhaps they did not meet minimum requirements), so the import will be aborted”
Any help as i really do not want to manually add users when we have information on a spreadsheet already to copy and paste over.
Thanks for your help as it is the Easter break from Friday and I would liek to get my teeth into this and understand all the small problems I am having.

Hi David, if you can email your import file (or at least the first row of it) to, we can take a look for you, and hopefully keep you moving in the right direction. Thanks, Ross.

Please can you help me import users?
This error is coming up:
Import cannot proceed, as the submitted file has a MIME-TYPE of application/octet-stream, and as such does not appear to be a CSV file.


It may help to open and re-save the file in a plain text editor, or Libre Office as the docs suggest: To use the built-in user importer the top line (with the column names) also needs to be removed.

It may be worth looking into the Data Admin module on the Gibbon Extend page. This module has a lot of flexibility when importing user data, allows more file types, and can help validate your data to ensure it imports correctly. In this case, you could import your file and leave the top like with column names in the file, and it lets you assign the columns ad-hoc. It also has an ‘Export Structure’ option which gives you a file with all the column names and you just fill in the data as needed.

Hope this helps!

Hi Sandra
thank you for helping! BUT DIDN’T WORK FOR ME.
I tried exactly what you told me to do…Copied the export structure and tried to import again: same message. I’m working in localhost in a trial instalation, v 16. I think it’s the only exception.
Msg is: Import cannot proceed, as the submitted file has a MIME-TYPE of application/octet-stream, and as such does not appear to be a CSV file.


I’ve edited your post to remove the attachment, on the chance that it may have contained personal data.

If you’re using the export structure from Data Admin then be sure to use the importer that’s part of the Data Admin module (rather than the built-in one). In this case, it looks like you’re using “Users Full”, so in Data Admin scroll down to the import called “Users Full” and click the gear to begin the import. I’ve tested it with the csv you attached and it looks good, no mime-type error.

Thank you Sandra, I used the import gear inside your Data Admin module. And the result is that error. It can possibly different from a server instalation if I installed in my computer?

Hmm, that is a bit odd, it must be something different system-to-system (or browser? os?) because the same file worked for me. One way to bypass the error for now might be to add “application/octet-stream” to the list of valid MIME-TYPEs, and hopefully it will still read properly by the CSV parser. Line 115-117 of modules/Data Admin/src/Importer.php` is an array of allowed mime-types, perhaps update it to the following list and see if that fixes the error:

`private $csvMimeTypes = array(
        'text/csv', 'text/xml', 'text/comma-separated-values', 'text/x-comma-separated-values', 'application/', 'application/csv', 'application/vnd.openxmlformats-officedocument.spreadsheetml.sheet', 'application/', 'application/msexcel', 'application/x-msexcel', 'application/x-ms-excel', 'application/x-excel', 'application/x-dos_ms_excel', 'application/xls', 'application/x-xls', 'application/vnd.oasis.opendocument.spreadsheet', 'application/octet-stream'

Hope this helps!