Import User-Data-Parent

Hi Admin & Ross,

I have problem when importing user data parent. On Step 3 (dry run) it look good and no errors. Reading File: Success, Validating Data: Success, Querying Database: Success, but when I press submit button (step 4) live run, it said “Your request failed because your inputs were invalid”. The file I was using from Export Columns (DataStructure-usersParents.xlsx).

Thank you for helping me.

Imam Nursianto

Hi Imam Nursianto,

We identified an issue with the v23 importer and have fixed it in v23.0.01. Are you able to check that you are using the latest version of Gibbon? If you’re not able to update your whole system at this time, I’d recommend applying the same changes as seen in the commit here:

Hope this helps!

Hi Sandra,

I am already in v23.0.01. I also check all files in resources/imports directory with the link you provided and already update. But still gives error.

Also I import Family-Family, it also give me the same error.

Thx for your help
Imam Nursianto

Hi Imam Nursianto, that sounds unusual. Are you able to share a screenshot? Sometimes in the error code it will indicate which column it ran into an error on. Generally, runtime errors on live import can occur if there is a clash in a unique field, such as two users with the same username.

Here are my screenshot.
Step 1.

Step 2

Step 3

Step 4

Imam Nursianto

Hi Imam Nursianto,

My apologies for the wait receiving a solution. I was able to test this out and confirmed that there appears to be an issue when selecting Update and Insert as the insert mode. I’ve added a fix to the v24 development branch, which can be seen here: You could either apply the same fix to your system manually, or change the mode in step one to “Insert” only, and this should resolve your issue.

Hi Sandra,

Thank you so much. It is worked.

Imam Nursianto

Glad to hear that it’s working!