HTTP Error 500

This error is coming.when I check the error log following error is showing
:09:24 UTC] PHP Warning: require_once(/home/isnwvq8o7ffx/public_html/cms/vendor/autoload.php): failed to open stream: No such file or directory in /home/isnwvq8o7ffx/public_html/cms/gibbon.php on line 21
[24-Apr-2019 17:09:24 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home/isnwvq8o7ffx/public_html/cms/vendor/autoload.php’ (include_path=‘.:/opt/alt/php70/usr/share/pear’) in /home/isnwvq8o7ffx/public_html/cms/gibbon.php on line 21

Please help me fix it

Hi Ghulam,

It looks like your vendor folder may either be missing or not readable by the server. It is located in the root of your Gibbon install, and should have file permissions for the system to access it (often 0755 for folders and 0644 for files).

I just checked the root . Vendor folder is missing. So now need further assistance.


Hi Ghulam,

If you access the same version you are using from our GitHub repo, then you can download it, unzip it, and upload the /vendor file to your server.



Respected Sandra,

Thanks for the quick worked.

Best regards,


how to solve HTTP 500 error?

after file copy of version 22.0 gibbon is not open show me http 500 error.

I tried two times and sure not a single file missing,

PHP Version 7.3.19-1

Hi @vishalr ,
Can you share your error log?

In Chrome PHP errors do tend to show as a HTTP 500 error, and so it is worth checking the logs, as Ghulam suggests. Let us know what you find.

[15-Jul-2021 07:51:44 UTC] This is an error message!
[15-Jul-2021 07:51:44 UTC] PHP Warning: require(/var/www/html/vendor/composer/…/markbaker/matrix/classes/src/Functions/adjoint.php): failed to open stream: No such file or directory in /var/www/html/vendor/composer/autoload_real.php on line 71
[15-Jul-2021 07:51:44 UTC] PHP Fatal error: require(): Failed opening required ‘/var/www/html/vendor/composer/…/markbaker/matrix/classes/src/Functions/adjoint.php’ (include_path=‘.:/usr/share/php’) in /var/www/html/vendor/composer/autoload_real.php on line 71

It definitely looks like some files are missing from /vendor, which is where we store the external PHP libraries that we use. Are you able to confirm that the specified files in require() are present or missing?

vendor/composer folder screenshot.

/var/www/html/vendor/composer/…/markbaker/matrix/classes/src/Functions/adjoint.php (Missing Files)

I think above file is missing in Zip files (

I tried to download file from git gibbon link but there is not show “vendor” folder.

Hi vishalr,

/vendor is no longer included in cutting edge code on GitHub, as it can become quite large. Instead, Cutting Edge installs need to use composer to download it. You can find details here. This is really only for developers.

For regular installations (e.g. stable code), /vendor is included in the install bundle for ease of installation.

The … in the path above means that you need to go up a director, and so you are looking at /vendor/markbaker/matrix/classes/src/Functions/adjoint.php. I’ve just downloaded the bundle and can indeed see that file:

Can you please check again, using the path provided above, and let us know if you can find adjoint.php?



Yes, this file is available on path (/vendor/markbaker/matrix/classes/src/Functions/adjoint.php)

@ghulamabbas92 have you getting same error at gibbon update time?

This feels like a permissions error. Is this file accessible to your web server? I know what this looks like on *nix systems, but not windows I am afraid. Ross