How to save changes in Home > User Admin > Manage Permissions

Hello, I am just trying to edit the settings to allow teachers to see each other’s timetables. I ticked the appropriate boxes but there is not option to “save” or “confirm” the settings and when I leave the page, it reverts back to the default settings. How can I save my changes? Many thanks…

I get this message:
php.ini max_input_vars=1000
Number of inputs on this page=1545
This form is very large and data will be truncated unless you edit php.ini. Add the line max_input_vars=3000 to your php.ini file on your server.

I have edited two different php.ini files and changed the value as indicated but still get the same message. Am I missing something obvious? Is there another php.ini file that I have missed?

I have now used the locate tool to find every instance of php.ini on the server and have changed all the max_input_vars values to 3000. After rebooting the server, the error message persists and I still can’t save my changes…

That is very odd. Can you let us know what kind of server you are running (e.g. OS, flavour and version, web server flavour and version, etc), and we will see what we can do to help.

It is Ubuntu Server 16.04 running Apache 2.

The file in question should be /etc/php/7.0/apache2/php.ini. Can you create a phpinfo page ( and see what it reports max vars as being? Then we’ll know if it is a Gibbon issue or a server issue. Thanks!

After changing these values, running sudo service apache2 reload should be sufficient to load the new settings, with restarting the apache service, or rebooting the whole machine.

Hopefully you’re able to sort this out via Ross’ suggestions above. Until then, as an interim solution, if you use the filters at the top to select one module or one role at a time, it reduces the overall number of inputs and you’ll likely be able to see the Submit button.

Thank you Ross and Sandra. It was very useful to know which file to edit. It was user error, I hadn’t uncommented the changed value! Works great now…