How to Remove Student and Staff Application form in Main Home Page?

Dear Support Team,

I want to remove Staff and Students Application form in Main Home page, Please Guide me how to do it?

Student application:
Admin> User Admin> Student Management> Application Form Settings> Public Applications? Set to No

Staff application:
Admin> User Admin> Staff Management> Staff Application Form Settings> Public Applications? Set to No



Thank you very much :slight_smile:

Thank you @meierrom !!!

Sorry I know this is an old post, however, I followed the instructions above, the staff application has gone but the student one remains, I have not created any custom forms this is a standard setup/install

Still showing

I have tried clearing the cache. it would be greate to have a hide welcome so it just shows the login box in the middle of the page

Hi @tmike Sorry for the confusion here. With the addition of the new application form and admissions module, this link is now controlled with School Admin > Admissions Settings. Turning this off should fix the issue. If not, be sure to check that the old application is also turned off in User Admin > Application Form Settings.

Hi Sandra, thanks for the reply,

The student link still shows on the home page:

I can remove it by commenting out the code block

    {% if admissionsEnabled %}
        {{ homepage.card(
        ) }}

    {% elseif publicStudentApplications %}
        {{ homepage.card(
            __('Student Applications'),
            __('Parents of students interested in study at %1$s may use our %2$s online form%3$s to initiate the application process.'),
        ) }}
    {% endif %} -->#}

It looks like you’ve turned of Public Registration, which is not quite the same as Student Applications. Be sure to check the settings in User Admin > Application Form Settings (rather than Public Registration Settings). Hope this helps!

Hi Sandra, under user admin I only have Public Reg settings, there is no link for Application form settings, to access that file I used url /index.php?q=%2Fmodules%2FUser+Admin%2FapplicationFormSettings.php

for some reason the links are not in the menu, I have not made any changes to the template files only the CSS

Oh shoot, sorry about that, I think the permission may have been turned off by default for new installations, favoring the new application form. If you go into User Admin > Manage Permissions, and look in the User Admin module, you should see an Application Form Settings permission that could be turned off for admin. If you turn that back on, you should see the page I mentioned. I’ll fix this for future installs, so that the old application form setting is turned off by default. My apologies for the confusion.