Google Integration

I have followed the steps at

to set up Google Integration. When I click on the “Sign in with Google” link I get this:

What could the problem be?

Hi Tieku, am I right in thinking that you are running Gibbon v20? What version of PHP are you running, and are you seeing any errors in your server’s logs?

I know I’ve seen this issue before, but it is not a bug as far as I recall (and we’ve not made any changes to this since v18 if I’m not mistaken), but some kind of config issue.



What seems to be happening is that line 76 of that file is returning true, rather than false. This may come down to the decision being made on line 67, which might then be related to session settings in PHP.

Hello Ross. Which file are you referring to?


The one that your screenshot is being generated by: /lib/google/index.php. this page should never show on its own, as you are experiencing. It should either be called within /index.php or redirect to Google or to other Gibbon pages. The fact that you are seeing it as a page on its own is a symptom of the issue you are encountering. Ross


Maybe check
It did fixed a similar issue for me.