Gibbon V13 , error while Exporting invoice (XLSX)

Best School management and amazing community.
for now I still learning how to setup Gibbon, but I noticed that V13 have issue while exporting invoices give error.

Luai, thanks for the positive feedback, and welcome to the community: we are still growing, but there are already many passionate users here. Please can you provide us with an error message for the issue you are experiencing. Keep in mind Gibbon v13 is not yet released (it is what we call Cutting Edge Code, still under development, due for release January 20th 2017): for production we recommend v12. Ross.

Hi Mr Ross,

First of all, I love Communities, and Gibbon is one of the best community, I am seeing bright future here.
it seems the issue was because of Mysql database problem, now exporting is working, but when I issue invoice the total amount got 0.00 USD, , and I am testing v13 because I love Gibbon and I want to see what improvement/Features is going to be and also to give feedback as possible to support this community :slight_smile:
I will Use V12 for Production… I still learning how to setup and use Gibbon.

Luai, such enthusiasm ; ) Are you assigning fees to your invoices? They can be predefined, or ad hoc. Ross.

I choose ad hoc with due date and also in fee I choose ad hoc and give “Reg” + the amount 1000.00 USD but when I issue it got to 0
What is the best stable server configuration should I setup for v12 to not have any problem with locale and language,etc (does Ubuntu Linux server should Work)?

Luai, as far as I can see this is all working fine for me in v13. Please can you send a screenshot of where you are seeing the issue, as this will help us track it down. If you want to email an export of your database to, that might help us locate the issue as well.

Yup Mr Ross, I will take screenshot and export the database to email. :slight_smile: Thanks alot for your support.

Now seem everything work prefect with v13, I dont know why I was having these issues, I will try to do more testing.
Thanks for your kindness support Mr Ross.

Hi Mr Ross,

Now in My ubuntu Server running v12 (production Use), the issue , please see the the photo in the attachment.

(This site can’t be reached

The webpage at might be temporarily down or it may have moved permanently to a new web address.)

Please how I can fix this issue ? I think its related to the Server?

Happy Thanksgiving day.

Kind Regards

Luai, this does sound like a server side issue. The best bet is to check your PHP error logs on the server side to see if there are any entries relating to this script. Can you do this and let me know? I wonder if you are using a PHP version lower than 5.5? That might cause some odd issues. Thanks!

Hi Mr Ross, Tomorrow Morning at the school I will check the server and PHP edition, unfortunately is still localhost :slight_smile:
everything is work perfectly, just exporting anything will show me this same error… I will look at php error logs, and back to you…
what is best method and stable server to install ? right now I am using Ubuntu 16.04 LTS. I will be happy if you could suggest one.
by the way I am looking forward to translating Gibbon to Arabic in the near future (within next month) I want to translate Gibbon to better Full Arabic language and choose nice Font.



Ubuntu is a good server platform to use, and is what I always run Gibbon from (except for development where I use MAMP).

Your contributions to the Arabic translation and localisation would be most appreciated If you email me on, I will add you to the team so you can get started when you are ready.



hi Admin/Ross,

My Server version is 5.7.16-0ubuntu0.16.04.1 - (ubuntu)
Server Charset : UTF -8 Unicode (utf8)
Web Server : Apache 2.4.18
Php Version : 7.0.8
Phpmyadmin : 4.5.4

please take a look at error.log , I hope if you could help me to fix it.

Thank you a lot

Hi Luai,

Based on your error log, it looks like the PHPExcel class is missing some dependencies: (from PHPExcel on github)

PHP extension php_zip
PHP extension php_xml
PHP extension php_gd2

These are usually installed with php, but depending on your install method they can occasionally be missing (I’ve run into this issue before and installing these extensions solved it). Given your php version the following command should install the extensions you need:

sudo apt-get install php7.0-gd php7.0-zip php7.0-xml`

Then restart: service apache2 restart`

Hope this helps!

Hi Skuipers,

Thank you a lot, This fixed the issue and now it works perfectly, I am very happy for your help :slight_smile:
Gibbon Is very Powerful SIS, I am wondering why you don’t make Gibbon ERP system? (Take a look at ERPNext school Beta) I think you could easy port Gibbon to the open source ERPNext (Frappe A full stack web Framework).

Thanks again for Mr Ross and for all the developers and community who is working on Gibbon the Flexible platform.

Have a great day,
Kind Regards