Gibbon only over a local network

I’m new to Gibbon and Linux based OS so I apologize if I have missed an obvious answer for the following.
I would like to run Gibbon over a local network; not to be accessed over the web. The server is running Ubuntu. Would it be better to use Windows? Also, is there a more in-depth guide I can follow from start to finish as it seems I’m missing something?

Thank you

Hi Will, no need to apologise, and welcome to the community. I prefer Linux (generally Ubuntu) to Windows for serving Gibbon. If you want it to be accessible locally, I would load the installer using http://localhost in your browser. It’ll then install on this local address and be unusable anywhere else. To secure it, use Ubuntu’s inbuilt firewall (ufw) to block access to port 80 (http) and 3306 (mysql). We don’t generally provide guides for server setup, as there are many more up to date guides out there…including

I hope this helps get you started : )


Thank you so much Ross; this is a big help.

The installer isn’t loading. When I go to locolhost, this is what I get:

Hi Will, my guess is that PHP is not installed into Apache, or is encountering some kind of error. The link below should help you determine if PHP is indeed at fault:



Any one have an idea to what I’m doing wrong/missing?


I made the test.php file but when opening in firefox I get a blank page and just the text in chromium. When running
php -r ‘echo "

Your PHP installation is working fine.

in terminal, it says “Your PHP installation is working fine.”

If you are getting a blank page in Firefox and raw PHP text in Chromium, then most likely PHP is not installed. Have you checked your Apache error logs? The terminal version of PHP is seperate from the web browser version, so it getting that result in terminal does not mean your web browser is working properly.

Error logs showed nothing. After trying a number of things with no luck, I decided to re-installed lamp. That got things going but now I have this on the Gibbon install page:
“The directory containing the Gibbon files is not currently writable, or config.php already exists in the root folder and is not empty or is not writable, so the installer cannot proceed.”

Hi Will,

Sounds like you’re getting closer. The directory where Gibbon is installed (and all the files in it) needs to have read/write access by the process running PHP. Generally, this means running the command chmod -R 755 on the path where Gibbon is installed.

Hope this helps!

HI Sandra,
Thanks for such a fast reply. I’m still learning as I go or I should say trial by fire. How do I run the command on the path? Could you show me an example please?

Is this look correct?
sudo chmod -R755 /var/www/html

Hi Will, I think if you add a space between -R and 755 it should work :+1:

Ran the command “sudo chmod -R 755 /var/www/html/Gibbon” (Gibbon being the folder I installed in). Unfortunately, I’m still getting the same issue. Thoughts?

Hmm, if you browse to that folder do you see that the permissions have changed to 755 (-rwxr-xr-x)? Depending on your setup (everyone’s a little different), you may also need to set the file ownership. For example, if my apache+php was running under the user www-data (which is typical for Ubuntu, but also can vary), I could use the commands: <code class="CodeInline">chgrp www-data /var/www/html/Gibbon -R
chown www-data /var/www/html/Gibbon -R`

Here’s a random search result that has some more info about how those two commands work:

Do you have any other webpages or web applications running? You could check their permissions & ownership and try the same settings with your Gibbon directory.

The only other way to see that error is if there’s already a config.php file in your Gibbon folder, but if you haven’t been able to install yet there shouldn’t be… worth a double-check though.

Use 777 then change it back to 755 afterwards.

Changing ownership of the gibbon site from root to www-data did the trick. Thanks a lot to both of you for getting me going. I have to follow up with the post install and server config… I may have some questions about that if I hit a wall again.

Glad to hear it worked!

Just for the record, for systems that use selinux you will also need:

chcon -R -t httpd_sys_rw_content_t

hi…hope you are doing well…
my question is…
how to connect gibbon and localhost?