Gibbon Escaped when logging in using Sign in With Google

Hello Gibbon Admins,

We have issues with Sign in With Google, the Gibbon escaped error message is showing however the Parent Login works perfectly fine.

The site is set to Trusted in Google API settings but still no luck.

Any advice is highly appreciated.

Thank you.

Tried running the php error logs and the top errors says server certificate ID does not match server name.

This issue is fixed. Our ssl cert is still valid but this error somehow showed up. Anyway, I tried restarting the server, restarting the apache and clearing the browser cache, then it worked.

False alarm! The error happened again. Not fixed. Any help is very much appreciated. Thanks!

Hi @Chellie In the end, in working together to fix the issue, it looks like it was related to SSL certificate settings being rejected by the SSO server because the ServerName in your Apache site configuration was missing and did not match the “Common Name” listed in the certificate itself. After fixing this, has the issue reoccurred? Otherwise, perhaps this solution may be of use to anyone else who has the same issue in the future. Thanks!

Thanks again @sandra for your help! As of today, everything is running smoothly. I suspect this was triggered when we had a long electricity cut-off during weekends. I will keep monitoring and will give updates if this issue reoccurs.