Getting Started

My school is being sold off by our parent company and we will lose our subscription to a commercial MIS package at the same time. We only currently have 41 students so a commercial package isn’t really viable. As the computing teacher and an open-source enthusiast, I have been looking for a solution to this. I like the look of Gibbon but am really starting from zero as I haven’t done anything like this before.

We have a server infrastructure in the school (Windows 2012) and a good, strong internet connection. All my experience so far has been with Python and C Sharp rather than PHP and HTML and so I am a complete noob regarding setting up something like this.

Is it feasible to set something up like this using our own infrastructure or would it be better to rent a commercial web server?

Do you have any recommendations as to first steps if I try to set this up on our own system? I have full access so could either use the inbuilt Microsoft web server functionality or install an Ubuntu or Fedora server in a virtual machine.

Many thanks in advance for any initial tips on getting started…

Hi Simon,

Welcome to the community: we are all noobs at something or other, and so you are in good company here!

My suggestion would be to start with a simple LAMP stack running on Ubuntu, as this is a more tested route for running Gibbon than Windows, and we will be more able to help you.

A lack of programming knowledge should not hinder you, unless your requirements vary considerably from what the project offers. However, the system is designed with flexibility in mind, and so hopefully meets your needs.

I’d suggest that you look at our Getting Start documentation in order to familiarise yourself with Gibbon’s nomenclature and data structures:

From here, you will hopefully be ready to dive into the system and start entering some of your data. @ross’s Data Admin module (available on our Extend page) will be useful here.

Let us know what else you need! Cheers,


Ok, so I set up an Ubuntu Server 16.04 install on a virtual machine on our school server and followed the step by step instructions on:

However at the sudo systemctl restart apache2
command, it refused to start Apache 2 and gave me an error message.

The line referred to looks fine:

Any advice for future troubleshooting?

The only difference I can see between my set up and the suggested one on this page was I haven’t set up a static IP address yet and it would be a 10.20. one rather than a 169.

Many thanks in advance…

That is interesting. Have you tried to comment that line out to see if it resolves the issue, or if it pushes it onto another area of the config?

It still crashes if i comment that line out, it even still refers to an error on that line…

Correction, it works now, I couldn’t get a proper hash character as I was remoting from a mac running Linux!

But the next stage stopped me,I cannot to connect to Gibbon to begin set up…

When I run the status command, I get an error that shows I haven’t got the URL working properly.

How can I fix this, sorry for the noob-style question but I haven’t set up a web server before…

No need to apologise for asking a question, we are all noobs at something or other!

In general the scope of our support efforts does not extend to server setup, but let us see what we can do to help. Your IP address is, which seems to be a local-network address. Do you have a public IP address for this server? And is that pointing to a domain name?

Let us know and we’ll see what we can do.

There is a public IP but it is refusing connections.

Correction, I can access it on the local network using but I get the Apache2 Ubuntu Default Page rather than Gibbon. According to the message, I should replace /var/www/html/index.html before continuing to operate the HTTP server.

At the moment, this file just contains the default Apache2 config. It probably should have been replaced when I installed Gibbon.

Ah great, you can simply removed index.html and then decompress the Gibbon download into that folder. When you browse to it will spot Gibbon’s index.php script and load that up. Gibbon will detect that it has not been installed, and forward you on to the installer. Good luck!

Thank you, I have got to the installer screen but some things are not installed and I cannot proceed…

What is next?

Progress! If you Google “ubuntu apache install php pdo” and “ubuntu apache install php gd” you should fine instructions on how to do this. You might need to check your PHP version to find the right commands. Good luck : )

I have now installed pdo and gd and got through to Step 3 but it just hangs on the page and doesn’t come up with the next options.

OK, I got past this, its working now!

Great you managed to install Gibbon on Ubuntu…
I still would like to advocate my little project as a base for gibbon: NethServer.
It is not Ubuntu, but CentOS based. Bedised that it has a wonderfull and helpfull community.
Have a look at the install howto for Gibbon on NethServer and decide if it is worth it to switch:

Besides an easy way to install Gibbon, NethServer is highly modular and has several point-and-click services ready for you to use. (for instance the option to join or create a Windows domain, mail-, file, print server, full gateway functionality etc…) If you have any questions, don’t hesitate to ask…

Hi @sdbaldwin I am glad to hear you got it sorted. I’m guessing you looked at your PHP error logs? v17 (landing January 20th 2019) has some more elegant error handling built in!

@robb_nl thanks for sharing NethServer, which looks like a very neat, active project and community. The depth of discussion on the post you shared about says a lot! I’ll look into NethServer next time I need to deploy a Gibbon instance.

Thank you for your comments above. I have now managed to kill my installation! Luckily I am only testing at the moment. I had installed V14, as I was following instructions on

Unfortunately, I was a bit heavy handed and replaced the entire /etc/var/html directory with the contents of the unzipped 16.0.01 version. When I go onto, I now get:

I realise, I will have to reinstall, but how do I get back to that point?

Thank you for all your help with this!