Free Learning Module

I have updated the module v5.21.07 to v5.22.09. After the update, teachers are not able to edit the units. However, Admins and Team heads are able to edit the units. Attaching the screenshot with error faced.
Thank you.

1 Like

HI @vishalr Looks like Ross found a bug shortly after that version was released, and has already fixed it and released v5.22.10, available here: Extend - Gibbon

Thanks @sandra

if I am not selected “Prerequisite Units” Then I am getting same error as above “The specified record cannot be found.” in Teacher account.

in Admin Account it is working fine.

So sorry, Ross has just informed me that there was one more fix, so we’ve just released v5.22.11 to address the prerequisites issue, which cropped up in edit and export. Normally we don’t tend to have back-to-back bugs, we’ve been working to train an intern on all things Gibbon and there’s a large learning curve, very easy to accidentally overlook a bug. Thanks again for your understanding :smile:

Hopefully, with timezones, you hadn’t seen the above message yet, in which case there is one more fix in v5.22.12. They were dealing with some tricky table joins and sql unions, but are pretty confident it’s all sorted out now :sweat_smile:

1 Like

Thank you @sandra , @rossdotparker and team. You have been super helpful as always.

1 Like