Free Learning Mentor group custom field

Hi there!
Great job with Gibbon! At first it has a bit of a steep learning curve but then you get used to how it works and it is really incredible.

I am using the Free Learning module for creating MOOC-type contents.
Gibbon Version 25.0.01

At the moment I managed to create different mentor groups for the module but I noticed that adding students “Automatically” to the group by means of a “Custom field” selection, the students do not get automatically accepted for the enrolment in learning Units, even if I switched that option to “Yes”!

Surprisingly, if I add them manually, they get automatically accepted when they enroll =')

Steps to reproduce:

  1. Create custom field in User – User Admin, set to Active, not Required but Hidden, Visibility to Students and included only in Data Updater
  2. Upload users with Import function (User - basic template) with an added a column with the created custom field name and according value (number in my case)
  3. Enroll Students with Import function (to have separate Year Groups)
  4. Create Unit on Free Learning with visibility for specific Year Groups
    Create Mentor group with mentors with Group Assignment “Automatic”, select Custom Field (which comes up correct) and insert the correct value.
  5. Try to enroll and get notification that my mentor (which is within the mentor group) will have to manually accept my enrolment request

At the moment I am a bit stuck, I need to check if it works if I insted use the Import function even for the Free Learning - School Mentorship.

Will give updates if it works!

Hi @eugene Welcome to the Gibbon community :smiley: It sounds like, despite the learning curve, that you’re off to an excellent start with Gibbon and are well into the more complex settings and options available, including importing data and using additional modules.

The mentor groups should be working as you describe. Thanks for sharing detailed steps to reproduce, I’ll plan to check this out in the coming days and see if I can find a cause.

In the meantime, can you check to see that your custom field data did indeed import correctly? As there is generally an extra step to importing custom field data beyond just adding a column to the importer, to properly json-ify the data on import. If that seems to be the case, check out the usersCustomData.yml import file, which can be customised for importing your particular custom field data.