Error message Help

HI, sorry for the confusion I may have given in my first post (new at this). I fixed 1 of my problem which was to download the Extend module. However now that my setup is done (this include the Post-Install and Server config). Once login to my site, I cannot add, delete, install the module, make absolutely any changes to get me started…every time I make a change and submit, I get a new window with the following error message:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator or webmaster to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an Error Document to handle the request.
My web host technician has no idea where it is originating from and will help once I can figure out where it comes from or what the issue is. Can anyone help to figure this out? Muche sunshine from the Caribbean to you all!

Hi Didier, welcome to the Gibbon community :smiley:

Is this error only occurring with the module downloaded from the Extend page? If so, it may be the file permissions for the downloaded module needs to be set to server readable (often 0644 for files, 0755 for directories). If you have FTP access to your server (directly, or through a client like FileZilla) you could try updating these permissions.

If you’re seeing the error elsewhere in Gibbon, does it show up every time you submit a form (including search forms), or only sometimes? The causes of a 500 error are likely server-side, such as file permissions, a syntax error in .htaccess, or other server configuration issues. If you visit the System Admin > System Check page, do you see any red Xs?

Dear Sandra, Thanks for the welcome! B)
This error occur through out the whole site regardless of what I do. Want to add a user, want to delete old school year in the demo section, want to change the grading from the default to percentages, cannot installed any modules that are downloaded and ready to be install…want to add a new school year or create terms, etc…literally for every function I am trying. …I am novice at all this stuff so…will try to answer your questions;
I use FTP to access my server through FileZilla and I will look at the permissions. I look at the system check and I do have an X in the File Extension Zip section…all the others are a green Tag…could this be the problem?
Thanks for help!

Dear DidierBC,
You have not installed Gibbon properly. You must go to softaculous from your CPanel and from softaculous find Gibbon and click on install It will automatically install Gibbon without any error and you will see no error.

Dear Ghulamabba92,
My Cpanel does not have Softaculous and I would not know how to add it my CP. Also my install on an Apache server (v2.4.35) running cloud Linux on a quad-core Intel Xeon processor of which I do not have the root access, to protect our data and avoiding me making a mess of it :):).
Prior to my install my web-host suggested not to use the Softaculous option. No sure why but because I am a novice I listened his suggestion.
Mind you that since my last post I noticed that I had an X in the system check which is related to an PHP extension Zip file that need to be installed. Due to the fact that I do not have the root access to my site, my web-host will be installing it. If this fail, I will suggest to him your option and see if it is at all possible…(again a real beginner at this)…
By the way, these error are coming after I log in, which I can log in without any issues and I see all the module and access them all quite easily…just cannot make any changes to any…with your help the help of others I am very hopeful to get through…I am working on switching platform and have 1 year before using it live, so quite a bit of time to learn and to iron any possible issues…
Thanks a million for the help. Will keep you posted after installing the extension file. Much Respect. Didier

Hi DidierBC, I wonder if this perhaps is related to .htaccess, perhaps your host has some settings that are incompatible with Gibbon’s additional modules. This is not something I’ve heard of before, but we’ve seen more general versions (e.g. impacting a whole install). I think permissions are more likely, but .htaccess might be worth considering. Good luck! Ross.

Thanks Ross. Will forward to him right away…by the way I can access the entire site, see screenshots…just not make any changes…

This is what my web host is asking? Can you help?

Hi Didier,

That might be the issue, but it’s hard to say unless they tell you what the .htaccess file should have in it. Here’s what yours has now…maybe you can send it to them to see if there’s something they want to add or change:

BEGIN cPanel-generated php ini directives, do not edit

Manual editing of this file may result in unexpected behavior.

To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)

For more information, read our documentation (

php_flag asp_tags Off php_flag display_errors Off php_value max_execution_time 30 php_value max_input_time 60 php_value max_input_vars 5000 php_value memory_limit 128M php_value post_max_size 8M php_value session.gc_maxlifetime 1440 php_value session.save_path "/var/cpanel/php/sessions/ea-php56" php_value upload_max_filesize 10M php_flag zlib.output_compression Off php_flag short_open_tag On # END cPanel-generated php ini directives, do not edit

Hope you can fix it!
Cheers, Didier

Hi Didier,

Hmm, those .htaccess settings seem okay to me. I tested them in my localhost and wasn’t able to reproduce your error.

It looks like display_errors is Off, so to see if there’s any errors you’d need to check the output file, or turn display_errors On for the time being. Looking at the most recent errors may help troubleshoot this issue.

Do you have access to check the PHP error logs for your server? Perhaps through cPanel (hopefully without having to ask your server person again). With FTP access, it may be in /var/log or /usr/local/cpanel/logs/error_log (all depends on your server setup).

Also, you mentioned a 500 Internal Server Error when initially setting up Gibbon, which you then moved the location of the core folder. It may help to double-check in System Settings that the Base URL and Base Path are both correct.

I’m sure we’ll figure this one out soon. Every server is a bit different, so these things can happen.

Sandra, for good measure and to be safe I forwarded your answer to my server person. He is quite willing to help to get me going. That said, I dont have access to the root system but have access to everything else…so will look in the mean time in the PHP and the FTP myself as well…need to learn this if I want ot be successful to launch Gibbon next September…that is a worry for me to have a site done for hours because I dont know how to fix these issues…will see when we get there…

Sandra, have no access through the FTP but I do via the CP and the error logs show this in the last 4 try… (hope this is what you are looking for)?
[Wed Oct 17 12:21:03.498401 2018] [core:alert] [pid 235007] [client] /home/sassonlineant/public_html/.htaccess: Options> directive missing closing ‘>’
[Wed Oct 17 12:21:03.498329 2018] [core:alert] [pid 235007] [client] /home/sassonlineant/public_html/.htaccess: Options> directive missing closing ‘>’
[Wed Oct 17 12:20:46.813251 2018] [core:alert] [pid 234892] [client] /home/sassonlineant/public_html/.htaccess: Options> directive missing closing ‘>’
[Wed Oct 17 12:20:46.813173 2018] [core:alert] [pid 234892] [client] /home/sassonlineant/public_html/.htaccess: Options> directive missing closing ‘>’

And just in caase, thisis the action I did before that…it shows other place I was on the site…
[Wed Oct 17 11:27:19.007631 2018] [:error] [pid 219640] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 11:24:33.024081 2018] [:error] [pid 217746] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 10:55:06.766958 2018] [:error] [pid 209964] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 10:47:28.932199 2018] [:error] [pid 207934] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 10:41:28.569318 2018] [:error] [pid 204928] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 10:40:52.659379 2018] [:error] [pid 205574] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Wed Oct 17 10:40:47.082587 2018] [:error] [pid 205419] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group, referer:
[Tue Oct 16 09:31:51.210154 2018] [:error] [pid 3544383] [client] SoftException in Application.cpp:651: Directory “/home/sassonlineant/public_html/modules/Finance” is writeable by group, referer:

Hmm, those are some interesting errors. A syntax issue in .htaccess it not good and should certainly be fixed… the snippet you shared must not have been the whole file? Looks like there’s a missing > on an `) tag (so sayeth the error message).

The second error looks like a server configuration that is quite strict about the file permissions to use. In this case, it seems unhappy that the directory permissions have a writeable bit. A quick google search gives some ideas on what to try:

Sandra, will pass that on to Michael my server host. This is what he said from last set of look, however I just tried and same thing happen, the 500 server error continue to happen.

Sorry I wasn’t able to help you today on this, but I just jumped in your account and updated the .htaccess file to set display_errors to “On” as Sandra asked. This way you can see any errors on the site when you run into them rather than seeing a “500 error” message. You can also see the server error log by accessing the link I sent you and clicking the “Errors” icon under the Metrics section. You can send Sandra any recent errors you see listed there to see if she can help further.

Sandra, further comments from Michael;
Hi Didier,

Looks like Sandra was commenting on some errors that I generated when checking out the .htaccess file myself and testing out a different configuration. She can disregard those as they were only temporary.

In the other hand, the later errors you saw that showed “Directory “/home/sassonlineant/public_html/modules/System Admin” is writeable by group” do show an issue in the software. I went ahead and removed the group-writable property from all folders in the “modules” folder as mentioned in the link she sent…let me know if that helps.

Sandra, I just log in after receiving the message above from Michael and once again in stand still?
After log in I tried 5 different things;

  1. Change the default theme (twice with different themes)
  2. Tried to install 2 different modules
  3. Try to change the default grading scale to percentages

All fail and continue to give me the same error??? Oh well…will keep searching…

Sandra, not sure what happen but suddenly the site is functional!!! Made changes to the grade scale, currency, changes the theme to Forest, installed one of the module…and all this without error thus far! Will keep my fingers cross for the week-end! Didier