Enrollment form

Hi All,

I have built an admissions form using the form builder. It works very well (well-done, gibbons) at entering the new student’s details into the database, but will not auto-enroll them into the correct homeroom or classes…

I’ve looked at the presets from the form builder and they seem correct but nothing I try seems to work. I would have thought that this was a fundamental reason for having an enrollment process direct to Gibbon.

Any advice on how to fix this?

Many thanks

Hi TShepherd,

Auto-enrolling students in classes uses the Timetable Admin > Sync Course Enrolment settings. Have you already set these up? Otherwise, the system won’t know which classes to auto-enrol students into depending on their homeroom.

Also, while parents can select the Year Group of Entry on the application, they cant select the specific homeroom to enrol in, so for auto-enrol to work the Form Group/Homeroom of Entry needs set in the Office Only fields before accepting the application. The acceptance page will give a warning that it cannot auto-enrol if this field is missing.

Hope this helps.

Thanks, Sandra.

I now have the Form Group option set as office only… I don’t see it on the form (when looking as an applicant) and do see it as the administrator accepting the student. However, when accepting the student there are no Form groups to choose from in the drop-down list… it’s empty.

We have everything else needed up and working… form groups year groups… but I just can’t get this auto-enroll to work…

Please help… losing my mind…

Hi TShepherd, one thing to check is that the form groups have been setup for the same school year of entry that you’ve selected. If you’re enrolling for a future year, then the form groups need to be setup for that year. You can use the Copy to Next Year tool in Manage Form Groups to copy them over. Otherwise, feel free to share some screenshots if it would help illustrate what you’re seeing.

Thank you… this seems to be where I had gone wrong… can’t enroll a student into an empty space :slight_smile:

Seems to be working fine now…

Many Thanks

Great to hear you got this working! :smiley: