codecept testing related issue - not able to install phpbrowser with codecept

It might not seem related, however, when trying to test using codecept, it will not work without phpbrowser and that would not install due to the following constraints:
Your requirements could not be resolved to an installable set of packages.

Problem 1
- codeception/module-filesystem[1.x-dev, 2.0.0] conflict with codeception/codeception <4.0.
- codeception/module-filesystem[2.0.1, …, 2.0.x-dev] conflict with codeception/codeception <4.1.
- codeception/module-filesystem[1.0.0, …, 1.0.2] require php >=5.6.0 <8.0 → your php version (8.0.13) does not satisfy that requirement.
- codeception/module-filesystem 1.0.3 requires codeception/codeception ^4.0 → satisfiable by codeception/codeception[4.0.0, …, 4.2.2] from composer repo ( but codeception/codeception is the root package and cannot be modified. See for details and assistance.
- codeception/codeception is present at version 1.0.0+no-version-set and cannot be modified by Composer
- Root composer.json requires codeception/module-filesystem ^1.0 | 2.0.*@dev → satisfiable by codeception/module-filesystem[1.0.0, …, 1.x-dev, 2.0.0, 2.0.1, 2.0.2, 2.0.x-dev].

You can also try re-running composer require with an explicit version constraint, e.g. “composer require codeception/module-phpbrowser:*” to figure out if any version is installable, or “composer require codeception/module-phpbrowser:^2.1” if you know which you need.

If you have faced such issue or are able to test using codecept, please share the details about which version of php, codecept and phpbrowser you have used for that.

Many thanks for your support.

Hi dkikan, that is odd. We do have codeception running as part of our continuous integration tests for the codebase, and it has been running smoothly, the GitHub action config can be found here. When you installed, did you do a straight composer install from the lockfile, without any <code class="CodeInline">composer update?