Chinese language no working


I instlled both Chinese languges but they do not work correctly.

System Default and Personal Language are both set to Chinese but everything is just in English.

The only way I could get it to some whot work is to set sytem Default to Chinese and Personal Language to something els in my case German only then a button on the top right corner appeared.

With this button i can set the language to Chinese.

But as soon as I click a link everything is back to English.

Hi lbister, this is very odd indeed. Usually, languages don’t work because the requisite locale is not installed on the server (at least for Posix based systems, such as Linux). What kind of server stack are you using. Are the two Chinese languages installed? If so, perhaps check your PHP error log to see if that contains any clues. Thanks! Ross.

Hi lbister

I “think” we were having similar problem when testing Gibbon v17 on our cloud server (ubuntu). The installation process was with some trial and error due to lack of experience, which in my opinion, may caused that problem.

Later on, we rent another Ubuntu to run Gibbon v18 production platform, this time the process was smoother (ie with all the lib, modules etc installed first etc) and that problem does not happen again. I can’t say what fixed that but sharing the most (if not all) of the steps we took during v18 installation for reference.


[Set up server] (May skip directly to Gibbon section if your server is running)

-Create sudo user account and user this account to do all installation.
adduser [username]

-Use the usermod command to add the user to the sudo group
usermod -aG sudo [username]

-Update apt-get
apt-get update
apt update

-Prepare some tools such as Unzip
sudo apt-get install unzip
sudo apt-get install php-php-gettext

-Install Apache
sudo apt-get install apache2

-Restart Apache
sudo systemctl restart apache2.service

-Modify the default virtual host, edit the file

-Install Curl
sudo apt-get install curl

-Install MySQL
sudo apt-get install mysql-server

-Securing MySQL server deployment
-Remove anonymous user (may be after all installation finished)
-Remove remote root login
-Remove test Database
sudo mysql_secure_installation

-Restart MySQL
sudo systemctl restart mysql.service

-Install PHP
sudo apt-get install php libapache2-mod-php
sudo apt-get install php-mysql
sudo apt-get install php-cli
sudo apt-get install php-cgi
sudo apt-get install php-pgsql

-Install phpMyAdmin
sudo apt-get install -y phpmyadmin
sudo service apache2 restart

-If cannot load phpMyAdmin from browser
-To set up under Apache all you need to do is include the following line in /etc/apache2/apache2.conf.
Include /etc/phpmyadmin/apache.conf

-Since Ubuntu 13.10 (Saucy Salamander), Apache no longer loads configuration files from the /etc/apache2/conf.d directory. Instead, they are placed in the /etc/apache2/conf-available directory which is managed with the a2enconf command. Therefore, if you need to manually include the phpMyAdmin-shipped Apache configuration file, you must run the following:
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo /etc/init.d/apache2 reload (or sudo systemctl reload apache2 ?)

-Secure and Lock Down phpMyAdmin Interface

-Configuring Password Access for the MySQL Root Account
sudo mysql
SELECT user,authentication_string,plugin,host FROM mysql.user;
ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘password’;

[Installing Gibbon]
-Download latest zip file

-Installation Guideline
sudo phpenmod pdo_mysql
sudo apt-get install php7.2-curl
sudo apt-get install php7.2-gd
sudo service apache2 restart

sudo a2enmod rewrite
systemctl restart apache2

sudo locale-gen zh_CN
sudo locale-gen zh_CN.utf8
(may add more languages)

-Create a Gibbon folder then unzip the Gibbon zip file, or etc
sudo chown -R www-data /var/www/html/[gibbon directory]/

-Go to phpMyAdmin, Create gibbon database, Create a user specific to this DB, grant all rights to this DB

-Open a browser, access the Gibbon folder just created, the index.php file should starts the installation process, do checking etc. Just follow the steps on the web interface

-Change PHP settings
-Search for max_input_vars, change value to 5000
sudo vi /etc/php/7.2/apache2/php.ini
sudo service apache2 restart

-Download and install Extension Modules, such as “Data Admin” module
-Download from Gibbon sites
-Upload and unzip these modules inside Gibbon’s “module” folder

-here starts Post Installation settings